Skip to content
Heist/ feed
Medium

GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation

Type: advisorySource: Official CVE List1 source record

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Announced Group revision 1
Original source ↗

CVE-2026-112105

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: cve:CVE-2026-112105

Passy

Source reference: /containers/cna/affected/0/product

Affected versions
Not stated in this record
Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "cpes": [
      "cpe:2.3:a:passy:passy:*:*:*:*:*:*:*:*"
    ],
    "vendor": "GlitterWare",
    "modules": [
      "TLS Handler"
    ],
    "product": "Passy",
    "versions": [
      {
        "status": "affected",
        "version": "1.10.0"
      },
      {
        "status": "affected",
        "version": "1.10.1"
      },
      {
        "status": "unaffected",
        "version": "1.10.2"
      }
    ]
  }
]
Related CVEs
CVE-2026-112105

Source reference: /cveMetadata/cveId

Publisher severity

medium

Source reference: /containers/cna/metrics

Event
#39804 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement