DEBIAN-CVE-2026-27820
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
DEBIAN-CVE-2026-27820
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-27820
ruby3.1
Source reference: /affected/0/package/name
- Affected versions
- 3.1.2-7
Source reference:
/affected/0/versions3.1.2-7+deb12u1Source reference:
/affected/0/versions3.1.2-7+hurd.1Source reference:
/affected/0/versions3.1.2-8Source reference:
/affected/0/versions3.1.2-8.1~exp1Source reference:
/affected/0/versions3.1.2-8.3Source reference:
/affected/0/versions3.1.2-8.4Source reference:
/affected/0/versions3.1.2-8.5Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
ruby3.3
Source reference: /affected/1/package/name
- Affected versions
- 3.3.8-2
Source reference:
/affected/1/versions3.3.8-2.1Source reference:
/affected/1/versions3.3.8-2.2Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
ruby3.3
Source reference: /affected/2/package/name
- Affected versions
- 3.3.8-2
Source reference:
/affected/2/versions3.3.8-2.1Source reference:
/affected/2/versions3.3.8-2.2Source reference:
/affected/2/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby3.1",
"purl": "pkg:deb/debian/ruby3.1?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.1.2-7",
"3.1.2-7+deb12u1",
"3.1.2-7+hurd.1",
"3.1.2-8",
"3.1.2-8.1~exp1",
"3.1.2-8.3",
"3.1.2-8.4",
"3.1.2-8.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27820.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby3.3",
"purl": "pkg:deb/debian/ruby3.3?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.3.8-2",
"3.3.8-2.1",
"3.3.8-2.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27820.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby3.3",
"purl": "pkg:deb/debian/ruby3.3?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.3.8-2",
"3.3.8-2.1",
"3.3.8-2.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27820.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56690 · Revision 1
- Added to Heist Feed
- Publisher date