Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-27809

Type: advisorySource: OSV1 source record

psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past the expected row size), decode_rle() raises ValueError which propagated all the way to the user, crashing psd.composite() and psd-tools export. decompress() already had a fallback that replaces failed channels with black pixels when result is None, but it never triggered because the ValueError from decode_rle() was not caught. The fix in version 1.12.2 wraps the decode_rle() call in a try/except so the existing fallback handles the error gracefully.

Announced Group revision 1
Original source ↗

DEBIAN-CVE-2026-27809

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-27809

psd-tools

Source reference: /affected/0/package/name

Affected versions
1.10.7+dfsg.1-1

Source reference: /affected/0/versions

1.10.9+dfsg.1-1

Source reference: /affected/0/versions

1.12.0+dfsg.1-1

Source reference: /affected/0/versions

1.12.1+dfsg.1-1

Source reference: /affected/0/versions

1.14.2+dfsg.1-1

Source reference: /affected/0/versions

1.14.3+dfsg.1-1

Source reference: /affected/0/versions

1.15.0+dfsg.1-1

Source reference: /affected/0/versions

1.16.0+dfsg.1-1

Source reference: /affected/0/versions

1.17.0+dfsg.1-1

Source reference: /affected/0/versions

1.17.4+dfsg.1-1

Source reference: /affected/0/versions

1.9.24+dfsg.1-1

Source reference: /affected/0/versions

1.9.28+dfsg.1-1

Source reference: /affected/0/versions

1.9.30+dfsg.1-1

Source reference: /affected/0/versions

1.9.31+dfsg.1-1

Source reference: /affected/0/versions

1.9.32+dfsg.1-1

Source reference: /affected/0/versions

1.9.34+dfsg.1-1

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

psd-tools

Source reference: /affected/1/package/name

Affected versions
1.10.7+dfsg.1-1

Source reference: /affected/1/versions

Fixed versions
1.10.7+dfsg.1-1+deb13u1

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

psd-tools

Source reference: /affected/2/package/name

Affected versions
1.10.7+dfsg.1-1

Source reference: /affected/2/versions

1.10.9+dfsg.1-1

Source reference: /affected/2/versions

1.12.0+dfsg.1-1

Source reference: /affected/2/versions

1.12.1+dfsg.1-1

Source reference: /affected/2/versions

Fixed versions
1.14.2+dfsg.1-1

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "psd-tools",
      "purl": "pkg:deb/debian/psd-tools?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "1.10.7+dfsg.1-1",
      "1.10.9+dfsg.1-1",
      "1.12.0+dfsg.1-1",
      "1.12.1+dfsg.1-1",
      "1.14.2+dfsg.1-1",
      "1.14.3+dfsg.1-1",
      "1.15.0+dfsg.1-1",
      "1.16.0+dfsg.1-1",
      "1.17.0+dfsg.1-1",
      "1.17.4+dfsg.1-1",
      "1.9.24+dfsg.1-1",
      "1.9.28+dfsg.1-1",
      "1.9.30+dfsg.1-1",
      "1.9.31+dfsg.1-1",
      "1.9.32+dfsg.1-1",
      "1.9.34+dfsg.1-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27809.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1.10.7+dfsg.1-1+deb13u1"
          }
        ]
      }
    ],
    "package": {
      "name": "psd-tools",
      "purl": "pkg:deb/debian/psd-tools?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "1.10.7+dfsg.1-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27809.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1.14.2+dfsg.1-1"
          }
        ]
      }
    ],
    "package": {
      "name": "psd-tools",
      "purl": "pkg:deb/debian/psd-tools?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "1.10.7+dfsg.1-1",
      "1.10.9+dfsg.1-1",
      "1.12.0+dfsg.1-1",
      "1.12.1+dfsg.1-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27809.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#57500 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement