Skip to content
Heist/ feed
MediumFix available

NGINX ngx_http_v3_module vulnerability

Type: advisorySource: OSV1 source record

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with OpenSSL versions <= OpenSSL 3.5.0 under certain configurations, a limited heap buffer overflow could happen while processing a TLS handshake. This can happen in a non-deterministic manner that is beyond the attacker's control. This may cause a heap buffer overflow in the NGINX worker process leading to a restart and/or limited data corruption. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or limited data corruption. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Announced Group revision 1
Original source ↗

BIT-nginx-gateway-2026-90439

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:BIT-nginx-gateway-2026-90439

nginx-gateway

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
1.30.0

Source reference: /affected/0/ranges

1.30.5

Source reference: /affected/0/ranges

1.31.6

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "SEMVER",
        "events": [
          {
            "introduced": "1.29.2"
          },
          {
            "fixed": "1.30.0"
          },
          {
            "introduced": "1.30.4"
          },
          {
            "fixed": "1.30.5"
          },
          {
            "introduced": "1.31.0"
          },
          {
            "fixed": "1.31.6"
          }
        ]
      }
    ],
    "package": {
      "name": "nginx-gateway",
      "purl": "pkg:bitnami/nginx-gateway",
      "ecosystem": "Bitnami"
    },
    "severity": [
      {
        "type": "CVSS_V4",
        "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
      }
    ],
    "database_specific": {
      "source": "https://github.com/bitnami/vulndb/tree/main/data/nginx-gateway/BIT-nginx-gateway-2026-90439.json"
    }
  }
]
Related CVEs
CVE-2026-90439

Source reference: /aliases

Publisher severity

medium

Source reference: /database_specific/severity

Linked CVE context

These ratings describe the referenced vulnerabilities and products. They are not a severity rating for every application using this dependency.

Event
#18767 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement