Skip to content
Heist/ feed
HighFix available

python-jupyter-server security update

Type: advisorySource: OSV1 source record

The backend for Jupyter web applications Security Fix(es): Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects to arbitrary external domains via values such as `///example.com`. An attacker can use a crafted login URL to redirect users to a malicious site and facilitate phishing attacks. This issue is fixed in version 2.18.0.(CVE-2025-61669) Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, a path traversal vulnerability in the REST API allows an authenticated user to escape the configured root_dir and access sibling directories whose names begin with the same prefix as the root_dir. For example, with a root_dir named "test", the API permits access to a sibling directory named "testtest" through a crafted request to the /api/contents endpoint using encoded path components. An attacker can read, write, and delete files in affected sibling directories. Multi-tenant deployments using predictable naming schemes are particularly at risk, as a user with a directory named "user1" could access directories for user10 through user19 and beyond. A user who can choose a single-character folder name could gain access to a significant number of sibling directories. Version 2.18.0 contains a fix. As a workaround, ensure folder names do not share a common prefix with a

Announced Group revision 1
Original source ↗

OESA-2026-4165

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:OESA-2026-4165

python-jupyter-server

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
2.13.0-4.oe2403sp3

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.13.0-4.oe2403sp3"
          }
        ]
      }
    ],
    "package": {
      "name": "python-jupyter-server",
      "purl": "pkg:rpm/openEuler/python-jupyter-server&distro=openEuler-24.03-LTS-SP3",
      "ecosystem": "openEuler:24.03-LTS-SP3"
    },
    "database_specific": {
      "source": "https://repo.openeuler.org/security/data/osv/OESA-2026-4165.json"
    },
    "ecosystem_specific": {
      "src": [
        "python-jupyter-server-2.13.0-4.oe2403sp3.src.rpm"
      ],
      "noarch": [
        "python3-jupyter-server-2.13.0-4.oe2403sp3.noarch.rpm"
      ]
    }
  }
]

Publisher severity

high

Source reference: /database_specific/severity

Event
#52100 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement