DEBIAN-CVE-2026-87908
multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.
DEBIAN-CVE-2026-87908
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-87908
node-multiparty
Source reference: /affected/0/package/name
- Affected versions
- 4.2.3-2
Source reference:
/affected/0/versions4.2.3-3Source reference:
/affected/0/versions4.2.3-4Source reference:
/affected/0/versions4.2.3-5Source reference:
/affected/0/versions4.3.0+~4.2.1-1Source reference:
/affected/0/versions4.3.0-1Source reference:
/affected/0/versions4.3.1+~4.2.1-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-multiparty
Source reference: /affected/1/package/name
- Affected versions
- 4.2.3-3
Source reference:
/affected/1/versions4.2.3-4Source reference:
/affected/1/versions4.2.3-5Source reference:
/affected/1/versions4.3.0+~4.2.1-1Source reference:
/affected/1/versions4.3.0-1Source reference:
/affected/1/versions4.3.1+~4.2.1-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-multiparty
Source reference: /affected/2/package/name
- Affected versions
- 4.2.3-3
Source reference:
/affected/2/versions4.2.3-4Source reference:
/affected/2/versions4.2.3-5Source reference:
/affected/2/versions4.3.0+~4.2.1-1Source reference:
/affected/2/versions4.3.0-1Source reference:
/affected/2/versions - Fixed versions
- 4.3.1+~4.2.1-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-multiparty",
"purl": "pkg:deb/debian/node-multiparty?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"4.2.3-2",
"4.2.3-3",
"4.2.3-4",
"4.2.3-5",
"4.3.0+~4.2.1-1",
"4.3.0-1",
"4.3.1+~4.2.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-87908.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-multiparty",
"purl": "pkg:deb/debian/node-multiparty?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"4.2.3-3",
"4.2.3-4",
"4.2.3-5",
"4.3.0+~4.2.1-1",
"4.3.0-1",
"4.3.1+~4.2.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-87908.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.1+~4.2.1-1"
}
]
}
],
"package": {
"name": "node-multiparty",
"purl": "pkg:deb/debian/node-multiparty?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"4.2.3-3",
"4.2.3-4",
"4.2.3-5",
"4.3.0+~4.2.1-1",
"4.3.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-87908.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #58545 · Revision 1
- Added to Heist Feed
- Publisher date