DEBIAN-CVE-2026-26345
SPIP before 4.4.8 contains a stored cross-site scripting (XSS) vulnerability in the public area triggered in certain edge-case usage patterns. The echapper_html_suspect() function does not adequately sanitize user-controlled content, allowing authenticated users with content-editing privileges (e.g., author-level roles and above) to inject malicious scripts. The injected payload may be rendered across multiple pages within the framework and execute in the browser context of other users, including administrators. Successful exploitation can allow attackers to perform actions in the security context of the victim user, including unauthorized modification of application state. This vulnerability is not mitigated by the SPIP security screen.
DEBIAN-CVE-2026-26345
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-26345
spip
Source reference: /affected/0/package/name
- Affected versions
- 4.4.10+dfsg-1
Source reference:
/affected/0/versions4.4.3+dfsg-1Source reference:
/affected/0/versions4.4.3+dfsg-1+deb13u1Source reference:
/affected/0/versions4.4.4+dfsg-1Source reference:
/affected/0/versions4.4.5+dfsg-1Source reference:
/affected/0/versions4.4.6+dfsg-1Source reference:
/affected/0/versions4.4.7+dfsg-1Source reference:
/affected/0/versions4.4.8+dfsg-1Source reference:
/affected/0/versions4.4.9+dfsg-1Source reference:
/affected/0/versions - Fixed versions
- 4.4.11+dfsg-0+deb13u1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
spip
Source reference: /affected/1/package/name
- Affected versions
- 4.4.3+dfsg-1
Source reference:
/affected/1/versions4.4.4+dfsg-1Source reference:
/affected/1/versions4.4.5+dfsg-1Source reference:
/affected/1/versions4.4.6+dfsg-1Source reference:
/affected/1/versions4.4.7+dfsg-1Source reference:
/affected/1/versions4.4.8+dfsg-1Source reference:
/affected/1/versions - Fixed versions
- 4.4.9+dfsg-1
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.11+dfsg-0+deb13u1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"4.4.10+dfsg-1",
"4.4.3+dfsg-1",
"4.4.3+dfsg-1+deb13u1",
"4.4.4+dfsg-1",
"4.4.5+dfsg-1",
"4.4.6+dfsg-1",
"4.4.7+dfsg-1",
"4.4.8+dfsg-1",
"4.4.9+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-26345.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.9+dfsg-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"4.4.3+dfsg-1",
"4.4.4+dfsg-1",
"4.4.5+dfsg-1",
"4.4.6+dfsg-1",
"4.4.7+dfsg-1",
"4.4.8+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-26345.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56271 · Revision 1
- Added to Heist Feed
- Publisher date