Skip to content
Heist/ feed
HighFix available

DEBIAN-CVE-2015-3246

Type: advisorySource: OSVKnown exploited1 source record

libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.

Announced Group revision 1
Original source ↗

DEBIAN-CVE-2015-3246

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2015-3246

libuser

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
1:0.62~dfsg-0.1

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

libuser

Source reference: /affected/1/package/name

Affected versions
Not stated in this record
Fixed versions
1:0.62~dfsg-0.1

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

libuser

Source reference: /affected/2/package/name

Affected versions
Not stated in this record
Fixed versions
1:0.62~dfsg-0.1

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1:0.62~dfsg-0.1"
          }
        ]
      }
    ],
    "package": {
      "name": "libuser",
      "purl": "pkg:deb/debian/libuser?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-3246.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1:0.62~dfsg-0.1"
          }
        ]
      }
    ],
    "package": {
      "name": "libuser",
      "purl": "pkg:deb/debian/libuser?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-3246.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1:0.62~dfsg-0.1"
          }
        ]
      }
    ],
    "package": {
      "name": "libuser",
      "purl": "pkg:deb/debian/libuser?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2015-3246.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]
Related CVEs
CVE-2015-3246

Source reference: /upstream

Publisher severity

high

Source reference: /severity/0/score

Linked CVE context

These ratings describe the referenced vulnerabilities and products. They are not a severity rating for every application using this dependency.

CVE-2015-3246 · Unrated

Libuser · Known exploited (CISA KEV)

Event
#72954 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement