Skip to content
Heist/ feed
HighFix available

Apache Tomcat: Cross-context authentication mix-up with Jakarta Authentication configured

Type: advisorySource: OSV1 source record

Improper Authentication vulnerability in Apache Tomcat. When Jakarta Authentication was configured with SimpleAuthConfigProvider as the default provider and multiple web application used that provider, the realm for the first web application to authenticate a request would be used for all web applications. This issue affects Apache Tomcat: from 11.0.0 through 11.0.25, from 10.1.0 through 10.1.59, from 9.0.0 through 9.0.121. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60, 9.0.122, which fixes the issue.

Announced Group revision 1
Original source ↗

BIT-tomcat-2026-75973

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:BIT-tomcat-2026-75973

tomcat

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
9.0.45

Source reference: /affected/0/ranges

10.1.60

Source reference: /affected/0/ranges

11.0.26

Source reference: /affected/0/ranges

9.0.122

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "SEMVER",
        "events": [
          {
            "introduced": "8.5.0"
          },
          {
            "fixed": "9.0.45"
          },
          {
            "introduced": "10.1.0"
          },
          {
            "fixed": "10.1.60"
          },
          {
            "introduced": "11.0.0"
          },
          {
            "fixed": "11.0.26"
          },
          {
            "introduced": "9.0.0"
          },
          {
            "fixed": "9.0.122"
          }
        ]
      }
    ],
    "package": {
      "name": "tomcat",
      "purl": "pkg:bitnami/tomcat",
      "ecosystem": "Bitnami"
    },
    "severity": [
      {
        "type": "CVSS_V3",
        "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
      }
    ],
    "database_specific": {
      "source": "https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2026-75973.json"
    }
  }
]
Related CVEs
CVE-2026-75973

Source reference: /aliases

Publisher severity

high

Source reference: /database_specific/severity

Event
#59548 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement