DEBIAN-CVE-2026-6471
Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
DEBIAN-CVE-2026-6471
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-6471
postgresql-15
Source reference: /affected/0/package/name
- Affected versions
- 15.10-0+deb12u1
Source reference:
/affected/0/versions15.11-0+deb12u1Source reference:
/affected/0/versions15.12-0+deb12u1Source reference:
/affected/0/versions15.12-0+deb12u2Source reference:
/affected/0/versions15.13-0+deb12u1Source reference:
/affected/0/versions15.14-0+deb12u1Source reference:
/affected/0/versions15.15-0+deb12u1Source reference:
/affected/0/versions15.16-0+deb12u1Source reference:
/affected/0/versions15.17-0+deb12u1Source reference:
/affected/0/versions15.18-0+deb12u1Source reference:
/affected/0/versions15.3-0+deb12u1Source reference:
/affected/0/versions15.3-1Source reference:
/affected/0/versions15.4-0+deb12u1Source reference:
/affected/0/versions15.4-1Source reference:
/affected/0/versions15.4-2Source reference:
/affected/0/versions15.4-3Source reference:
/affected/0/versions15.5-0+deb12u1Source reference:
/affected/0/versions15.6-0+deb12u1Source reference:
/affected/0/versions15.7-0+deb12u1Source reference:
/affected/0/versions15.8-0+deb12u1Source reference:
/affected/0/versions15.9-0+deb12u1Source reference:
/affected/0/versions - Fixed versions
- 15.19-0+deb12u1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
postgresql-17
Source reference: /affected/1/package/name
- Affected versions
- 17.10-0+deb13u1
Source reference:
/affected/1/versions17.5-1Source reference:
/affected/1/versions17.6-0+deb13u1Source reference:
/affected/1/versions17.6-1Source reference:
/affected/1/versions17.7-0+deb13u1Source reference:
/affected/1/versions17.8-0+deb13u1Source reference:
/affected/1/versions17.9-0+deb13u1Source reference:
/affected/1/versions - Fixed versions
- 17.11-0+deb13u1
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
postgresql-18
Source reference: /affected/2/package/name
- Affected versions
- 18.0-1
Source reference:
/affected/2/versions18.1-1Source reference:
/affected/2/versions18.1-2Source reference:
/affected/2/versions18.2-1Source reference:
/affected/2/versions18.3-1Source reference:
/affected/2/versions18.4-1Source reference:
/affected/2/versions18~beta1+20250612-1Source reference:
/affected/2/versions18~beta1+20250624-1Source reference:
/affected/2/versions18~beta1+20250701-1Source reference:
/affected/2/versions18~beta1-1Source reference:
/affected/2/versions18~beta2-1Source reference:
/affected/2/versions18~beta3-1Source reference:
/affected/2/versions18~rc1-1Source reference:
/affected/2/versions18~rc1-2Source reference:
/affected/2/versions18~rc1-3Source reference:
/affected/2/versions18~~devel.20250318+g4078da6c478-1Source reference:
/affected/2/versions18~~devel.20250331-1Source reference:
/affected/2/versions18~~devel.20250405-1Source reference:
/affected/2/versions18~~devel.20250421-1Source reference:
/affected/2/versions18~~devel.20250502-1Source reference:
/affected/2/versions - Fixed versions
- 18.6-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "15.19-0+deb12u1"
}
]
}
],
"package": {
"name": "postgresql-15",
"purl": "pkg:deb/debian/postgresql-15?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"15.10-0+deb12u1",
"15.11-0+deb12u1",
"15.12-0+deb12u1",
"15.12-0+deb12u2",
"15.13-0+deb12u1",
"15.14-0+deb12u1",
"15.15-0+deb12u1",
"15.16-0+deb12u1",
"15.17-0+deb12u1",
"15.18-0+deb12u1",
"15.3-0+deb12u1",
"15.3-1",
"15.4-0+deb12u1",
"15.4-1",
"15.4-2",
"15.4-3",
"15.5-0+deb12u1",
"15.6-0+deb12u1",
"15.7-0+deb12u1",
"15.8-0+deb12u1",
"15.9-0+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6471.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.11-0+deb13u1"
}
]
}
],
"package": {
"name": "postgresql-17",
"purl": "pkg:deb/debian/postgresql-17?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"17.10-0+deb13u1",
"17.5-1",
"17.6-0+deb13u1",
"17.6-1",
"17.7-0+deb13u1",
"17.8-0+deb13u1",
"17.9-0+deb13u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6471.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.6-1"
}
]
}
],
"package": {
"name": "postgresql-18",
"purl": "pkg:deb/debian/postgresql-18?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"18.0-1",
"18.1-1",
"18.1-2",
"18.2-1",
"18.3-1",
"18.4-1",
"18~beta1+20250612-1",
"18~beta1+20250624-1",
"18~beta1+20250701-1",
"18~beta1-1",
"18~beta2-1",
"18~beta3-1",
"18~rc1-1",
"18~rc1-2",
"18~rc1-3",
"18~~devel.20250318+g4078da6c478-1",
"18~~devel.20250331-1",
"18~~devel.20250405-1",
"18~~devel.20250421-1",
"18~~devel.20250502-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6471.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #58262 · Revision 1
- Added to Heist Feed
- Publisher date