Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-40176

Type: advisorySource: OSV1 source record

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

Announced Group revision 1
Original source ↗

DEBIAN-CVE-2026-40176

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-40176

composer

Source reference: /affected/0/package/name

Affected versions
2.5.5-1

Source reference: /affected/0/versions

2.5.5-1+deb12u1

Source reference: /affected/0/versions

2.5.5-1+deb12u2

Source reference: /affected/0/versions

2.5.5-1+deb12u3

Source reference: /affected/0/versions

Fixed versions
2.5.5-1+deb12u4

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

composer

Source reference: /affected/1/package/name

Affected versions
2.8.8-1

Source reference: /affected/1/versions

2.8.8-1+deb13u1

Source reference: /affected/1/versions

Fixed versions
2.8.8-1+deb13u2

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

composer

Source reference: /affected/2/package/name

Affected versions
2.8.10-1

Source reference: /affected/2/versions

2.8.11-1

Source reference: /affected/2/versions

2.8.11-2

Source reference: /affected/2/versions

2.8.12-1

Source reference: /affected/2/versions

2.8.8-1

Source reference: /affected/2/versions

2.8.9-1

Source reference: /affected/2/versions

2.9.0~rc1-1

Source reference: /affected/2/versions

2.9.1-1

Source reference: /affected/2/versions

2.9.2-1

Source reference: /affected/2/versions

2.9.3-1

Source reference: /affected/2/versions

2.9.4-1

Source reference: /affected/2/versions

2.9.5-1

Source reference: /affected/2/versions

Fixed versions
2.9.7-1

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.5.5-1+deb12u4"
          }
        ]
      }
    ],
    "package": {
      "name": "composer",
      "purl": "pkg:deb/debian/composer?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "2.5.5-1",
      "2.5.5-1+deb12u1",
      "2.5.5-1+deb12u2",
      "2.5.5-1+deb12u3"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-40176.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.8.8-1+deb13u2"
          }
        ]
      }
    ],
    "package": {
      "name": "composer",
      "purl": "pkg:deb/debian/composer?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "2.8.8-1",
      "2.8.8-1+deb13u1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-40176.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.9.7-1"
          }
        ]
      }
    ],
    "package": {
      "name": "composer",
      "purl": "pkg:deb/debian/composer?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "2.8.10-1",
      "2.8.11-1",
      "2.8.11-2",
      "2.8.12-1",
      "2.8.8-1",
      "2.8.9-1",
      "2.9.0~rc1-1",
      "2.9.1-1",
      "2.9.2-1",
      "2.9.3-1",
      "2.9.4-1",
      "2.9.5-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-40176.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#56014 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement