DEBIAN-CVE-2026-22205
SPIP versions prior to 4.4.10 contain an authentication bypass vulnerability caused by PHP type juggling that allows unauthenticated attackers to access protected information. Attackers can exploit loose type comparisons in authentication logic to bypass login verification and retrieve sensitive internal data.
DEBIAN-CVE-2026-22205
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-22205
spip
Source reference: /affected/0/package/name
- Affected versions
- 4.4.10+dfsg-1
Source reference:
/affected/0/versions4.4.3+dfsg-1Source reference:
/affected/0/versions4.4.3+dfsg-1+deb13u1Source reference:
/affected/0/versions4.4.4+dfsg-1Source reference:
/affected/0/versions4.4.5+dfsg-1Source reference:
/affected/0/versions4.4.6+dfsg-1Source reference:
/affected/0/versions4.4.7+dfsg-1Source reference:
/affected/0/versions4.4.8+dfsg-1Source reference:
/affected/0/versions4.4.9+dfsg-1Source reference:
/affected/0/versions - Fixed versions
- 4.4.11+dfsg-0+deb13u1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
spip
Source reference: /affected/1/package/name
- Affected versions
- 4.4.3+dfsg-1
Source reference:
/affected/1/versions4.4.4+dfsg-1Source reference:
/affected/1/versions4.4.5+dfsg-1Source reference:
/affected/1/versions4.4.6+dfsg-1Source reference:
/affected/1/versions4.4.7+dfsg-1Source reference:
/affected/1/versions4.4.8+dfsg-1Source reference:
/affected/1/versions4.4.9+dfsg-1Source reference:
/affected/1/versions - Fixed versions
- 4.4.10+dfsg-1
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.11+dfsg-0+deb13u1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"4.4.10+dfsg-1",
"4.4.3+dfsg-1",
"4.4.3+dfsg-1+deb13u1",
"4.4.4+dfsg-1",
"4.4.5+dfsg-1",
"4.4.6+dfsg-1",
"4.4.7+dfsg-1",
"4.4.8+dfsg-1",
"4.4.9+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-22205.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.10+dfsg-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"4.4.3+dfsg-1",
"4.4.4+dfsg-1",
"4.4.5+dfsg-1",
"4.4.6+dfsg-1",
"4.4.7+dfsg-1",
"4.4.8+dfsg-1",
"4.4.9+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-22205.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56211 · Revision 1
- Added to Heist Feed
- Publisher date