Skip to content
Heist/ feed
UnratedFix available

ALPINE-CVE-2026-14681

Type: advisorySource: OSV1 source record

Improper enforcement of message integrity in PostgreSQL GSSAPI support allows a user to negotiate GSSAPI contrary to pg_hba.conf rules, via initial direct TLS connection. Despite a pg_hba.conf that appears to require GSSAPI, the connection may exchange data over TLS encryption alone. If the TLS settings are more permissive than the GSS settings, the connection may continue with lesser protection. Within major versions 17-18, minor versions before PostgreSQL 18.6 and 17.11 are affected. Versions before PostgreSQL 17 are unaffected.

Announced Group revision 1
Original source ↗

ALPINE-CVE-2026-14681

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:ALPINE-CVE-2026-14681

postgresql17

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
17.11-r0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

postgresql17

Source reference: /affected/1/package/name

Affected versions
Not stated in this record
Fixed versions
17.11-r0

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

postgresql17

Source reference: /affected/2/package/name

Affected versions
Not stated in this record
Fixed versions
17.11-r0

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

postgresql17

Source reference: /affected/3/package/name

Affected versions
Not stated in this record
Fixed versions
17.11-r0

Source reference: /affected/3/ranges

Prerequisites
Not stated in this record

postgresql18

Source reference: /affected/4/package/name

Affected versions
Not stated in this record
Fixed versions
18.5-r0

Source reference: /affected/4/ranges

Prerequisites
Not stated in this record

postgresql18

Source reference: /affected/5/package/name

Affected versions
Not stated in this record
Fixed versions
18.5-r0

Source reference: /affected/5/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "17.11-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql17",
      "purl": "pkg:apk/alpine/postgresql17?arch=source",
      "ecosystem": "Alpine:v3.21"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "17.11-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql17",
      "purl": "pkg:apk/alpine/postgresql17?arch=source",
      "ecosystem": "Alpine:v3.22"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "17.11-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql17",
      "purl": "pkg:apk/alpine/postgresql17?arch=source",
      "ecosystem": "Alpine:v3.23"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "17.11-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql17",
      "purl": "pkg:apk/alpine/postgresql17?arch=source",
      "ecosystem": "Alpine:v3.24"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "18.5-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql18",
      "purl": "pkg:apk/alpine/postgresql18?arch=source",
      "ecosystem": "Alpine:v3.23"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "18.5-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql18",
      "purl": "pkg:apk/alpine/postgresql18?arch=source",
      "ecosystem": "Alpine:v3.24"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-14681.json"
    },
    "ecosystem_specific": {}
  }
]

Publisher severity

No explicit severity was provided.

Event
#52229 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement