Skip to content
Heist/ feed
Medium

Apache Camel: Camel-Crypto-PGP Integrity Verification Downgrade via Attacker-Controlled Message Structure

Type: advisorySource: Official CVE List1 source record

Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. unmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected data packet. The older symmetrically encrypted data packet carries no such code, and OpenPGP's CFB mode is malleable without one, so a message using that packet skipped the check altogether. The packet type is chosen by whoever produced the message, which left the sender - or anyone able to rewrite the message in transit - deciding whether the integrity check applied at all. The existing integrity option governs marshalling only and had no decrypt-side counterpart, so a deployment could not require integrity protection on the messages it accepted. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A requireIntegrityProtection option, defaulting to true, now rejects a message that is not integrity protected. Note that signatureVerificationOption still defaults to optional, so a message carrying no signature is accepted; the two options together are what give a decrypted message authenticity and not only confidentiality. For deployments that cannot upgrade immediately, reject messages that do not use the integrity protected packet be

Announced Group revision 1
Original source ↗

CVE-2026-85243

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: cve:CVE-2026-85243

Apache Camel

Source reference: /containers/cna/affected/0/product

Affected versions
Not stated in this record
Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "vendor": "Apache Software Foundation",
    "product": "Apache Camel",
    "versions": [
      {
        "status": "affected",
        "version": "4.0.0",
        "lessThan": "4.18.5",
        "versionType": "maven"
      },
      {
        "status": "affected",
        "version": "4.19.0",
        "lessThan": "4.22.1",
        "versionType": "maven"
      },
      {
        "status": "unaffected",
        "version": "4.18.5",
        "versionType": "maven"
      },
      {
        "status": "unaffected",
        "version": "4.22.1",
        "versionType": "maven"
      },
      {
        "status": "unaffected",
        "version": "4.23.0",
        "versionType": "maven"
      }
    ],
    "packageURL": "pkg:maven/org.apache.camel/camel-crypto-pgp",
    "packageName": "org.apache.camel:camel-crypto-pgp",
    "collectionURL": "https://repo.maven.apache.org/maven2",
    "defaultStatus": "unaffected"
  }
]
Related CVEs
CVE-2026-85243

Source reference: /cveMetadata/cveId

Publisher severity

medium

Source reference: /containers/cna/metrics

Event
#39896 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement