Skip to content
Heist/ feed
Low

Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

Type: advisorySource: Official CVE List1 source record

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Announced Group revision 1
Original source ↗

CVE-2026-94220

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: cve:CVE-2026-94220

Apache APISIX

Source reference: /containers/cna/affected/0/product

Affected versions
Not stated in this record
Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "vendor": "Apache Software Foundation",
    "product": "Apache APISIX",
    "versions": [
      {
        "status": "affected",
        "version": "3.17.0",
        "versionType": "semver",
        "lessThanOrEqual": "3.18.0"
      }
    ],
    "defaultStatus": "unaffected"
  }
]
Related CVEs
CVE-2026-94220

Source reference: /cveMetadata/cveId

Publisher severity

low

Source reference: /containers/cna/metrics

Event
#5289 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement