Skip to content
Heist/ feed
HighFix available

Discourse: Reject literal backslash path separators in iframe src traversal guard

Type: advisorySource: OSV1 source record

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the iframe src traversal guard did not treat literal backslashes as path separators after decoded dot segments. A crafted source could therefore pass an allowed_iframes subpath check while browser URL normalization moved the iframe outside the intended allowed path. The resulting iframe could load content from a location that the administrator did not allow. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

Announced Group revision 1
Original source ↗

BIT-discourse-2026-91123

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:BIT-discourse-2026-91123

discourse

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
2026.8.0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "SEMVER",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2026.8.0"
          }
        ]
      }
    ],
    "package": {
      "name": "discourse",
      "purl": "pkg:bitnami/discourse",
      "ecosystem": "Bitnami"
    },
    "severity": [
      {
        "type": "CVSS_V3",
        "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
      }
    ],
    "database_specific": {
      "source": "https://github.com/bitnami/vulndb/tree/main/data/discourse/BIT-discourse-2026-91123.json"
    }
  }
]
Related CVEs
CVE-2026-91123

Source reference: /aliases

Publisher severity

high

Source reference: /database_specific/severity

Linked CVE context

These ratings describe the referenced vulnerabilities and products. They are not a severity rating for every application using this dependency.

Event
#59611 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement