UBUNTU-CVE-2017-5843
Multiple use-after-free vulnerabilities in the (1) gst_mini_object_unref, (2) gst_tag_list_unref, and (3) gst_mxf_demux_update_essence_tracks functions in GStreamer before 1.10.3 allow remote attackers to cause a denial of service (crash) via vectors involving stream tags, as demonstrated by 02785736.mxf.
UBUNTU-CVE-2017-5843
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:UBUNTU-CVE-2017-5843
gst-plugins-bad0.10
Source reference: /affected/0/package/name
- Affected versions
- 0.10.23-7ubuntu2
Source reference:
/affected/0/versions0.10.23-7.2ubuntu1Source reference:
/affected/0/versions0.10.23-7.2ubuntu1.1Source reference:
/affected/0/versions0.10.23-7.2ubuntu1.2Source reference:
/affected/0/versions0.10.23-7.2ubuntu1.3Source reference:
/affected/0/versions - Fixed versions
- 0.10.23-7.2ubuntu1.3+esm1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
gst-plugins-bad1.0
Source reference: /affected/1/package/name
- Affected versions
- 1.2.0-3ubuntu5
Source reference:
/affected/1/versions1.2.1-1ubuntu1Source reference:
/affected/1/versions1.2.1-1ubuntu2Source reference:
/affected/1/versions1.2.2-1ubuntu1Source reference:
/affected/1/versions1.2.2-1ubuntu2Source reference:
/affected/1/versions1.2.2-1ubuntu4Source reference:
/affected/1/versions1.2.3-1ubuntu1Source reference:
/affected/1/versions1.2.3-1ubuntu2Source reference:
/affected/1/versions1.2.4-1~ubuntu1Source reference:
/affected/1/versions1.2.4-1~ubuntu1.1Source reference:
/affected/1/versions1.2.4-1~ubuntu1.1+esm1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
gst-plugins-bad1.0
Source reference: /affected/2/package/name
- Affected versions
- 1.6.0-1ubuntu1
Source reference:
/affected/2/versions1.6.1-1ubuntu1Source reference:
/affected/2/versions1.6.2-1ubuntu1Source reference:
/affected/2/versions1.7.1-1ubuntu1Source reference:
/affected/2/versions1.7.1-1ubuntu3Source reference:
/affected/2/versions1.7.1-1ubuntu4Source reference:
/affected/2/versions1.7.2-1ubuntu1Source reference:
/affected/2/versions1.7.90-1ubuntu2Source reference:
/affected/2/versions1.7.91-1ubuntu1Source reference:
/affected/2/versions1.8.0-1ubuntu1Source reference:
/affected/2/versions1.8.1-1ubuntu0.1Source reference:
/affected/2/versions1.8.2-1ubuntu0.1Source reference:
/affected/2/versions1.8.2-1ubuntu0.2Source reference:
/affected/2/versions1.8.3-1ubuntu0.2Source reference:
/affected/2/versions1.8.3-1ubuntu0.2+esm1Source reference:
/affected/2/versions1.8.3-1ubuntu0.2+esm2Source reference:
/affected/2/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.23-7.2ubuntu1.3+esm1"
}
]
}
],
"package": {
"name": "gst-plugins-bad0.10",
"purl": "pkg:deb/ubuntu/gst-plugins-bad0.10?arch=source&distro=trusty%2Fesm",
"ecosystem": "Ubuntu:Pro:14.04:LTS"
},
"versions": [
"0.10.23-7ubuntu2",
"0.10.23-7.2ubuntu1",
"0.10.23-7.2ubuntu1.1",
"0.10.23-7.2ubuntu1.2",
"0.10.23-7.2ubuntu1.3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5843.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gstreamer0.10-plugins-bad",
"binary_version": "0.10.23-7.2ubuntu1.3+esm1"
},
{
"binary_name": "libgstreamer-plugins-bad0.10-0",
"binary_version": "0.10.23-7.2ubuntu1.3+esm1"
}
],
"availability": "Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gst-plugins-bad1.0",
"purl": "pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-infra-legacy%2Ftrusty",
"ecosystem": "Ubuntu:Pro:14.04:LTS"
},
"versions": [
"1.2.0-3ubuntu5",
"1.2.1-1ubuntu1",
"1.2.1-1ubuntu2",
"1.2.2-1ubuntu1",
"1.2.2-1ubuntu2",
"1.2.2-1ubuntu4",
"1.2.3-1ubuntu1",
"1.2.3-1ubuntu2",
"1.2.4-1~ubuntu1",
"1.2.4-1~ubuntu1.1",
"1.2.4-1~ubuntu1.1+esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5843.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gstreamer1.0-hybris",
"binary_version": "1.2.4-1~ubuntu1.1+esm1"
},
{
"binary_name": "gstreamer1.0-plugins-bad",
"binary_version": "1.2.4-1~ubuntu1.1+esm1"
},
{
"binary_name": "gstreamer1.0-plugins-bad-faad",
"binary_version": "1.2.4-1~ubuntu1.1+esm1"
},
{
"binary_name": "gstreamer1.0-plugins-bad-videoparsers",
"binary_version": "1.2.4-1~ubuntu1.1+esm1"
},
{
"binary_name": "libgstreamer-plugins-bad1.0-0",
"binary_version": "1.2.4-1~ubuntu1.1+esm1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gst-plugins-bad1.0",
"purl": "pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-apps-legacy%2Fxenial",
"ecosystem": "Ubuntu:Pro:16.04:LTS"
},
"versions": [
"1.6.0-1ubuntu1",
"1.6.1-1ubuntu1",
"1.6.2-1ubuntu1",
"1.7.1-1ubuntu1",
"1.7.1-1ubuntu3",
"1.7.1-1ubuntu4",
"1.7.2-1ubuntu1",
"1.7.90-1ubuntu2",
"1.7.91-1ubuntu1",
"1.8.0-1ubuntu1",
"1.8.1-1ubuntu0.1",
"1.8.2-1ubuntu0.1",
"1.8.2-1ubuntu0.2",
"1.8.3-1ubuntu0.2",
"1.8.3-1ubuntu0.2+esm1",
"1.8.3-1ubuntu0.2+esm2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5843.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gir1.2-gst-plugins-bad-1.0",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
},
{
"binary_name": "gstreamer1.0-hybris",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
},
{
"binary_name": "gstreamer1.0-plugins-bad",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
},
{
"binary_name": "gstreamer1.0-plugins-bad-faad",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
},
{
"binary_name": "gstreamer1.0-plugins-bad-videoparsers",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
},
{
"binary_name": "libgstreamer-plugins-bad1.0-0",
"binary_version": "1.8.3-1ubuntu0.2+esm2"
}
]
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #51927 · Revision 1
- Added to Heist Feed
- Publisher date