DEBIAN-CVE-2026-49477
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.
DEBIAN-CVE-2026-49477
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-49477
soupsieve
Source reference: /affected/0/package/name
- Affected versions
- 2.3.2-1
Source reference:
/affected/0/versions2.4-1Source reference:
/affected/0/versions2.4.1-1Source reference:
/affected/0/versions2.4.1-2Source reference:
/affected/0/versions2.5-1Source reference:
/affected/0/versions2.6-1Source reference:
/affected/0/versions2.7-1Source reference:
/affected/0/versions2.7-2Source reference:
/affected/0/versions2.8.1-1Source reference:
/affected/0/versions2.8.3-1Source reference:
/affected/0/versions2.8.4-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
soupsieve
Source reference: /affected/1/package/name
- Affected versions
- 2.7-1
Source reference:
/affected/1/versions2.7-2Source reference:
/affected/1/versions2.8.1-1Source reference:
/affected/1/versions2.8.3-1Source reference:
/affected/1/versions2.8.4-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
soupsieve
Source reference: /affected/2/package/name
- Affected versions
- 2.7-1
Source reference:
/affected/2/versions2.7-2Source reference:
/affected/2/versions2.8.1-1Source reference:
/affected/2/versions2.8.3-1Source reference:
/affected/2/versions - Fixed versions
- 2.8.4-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "soupsieve",
"purl": "pkg:deb/debian/soupsieve?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.3.2-1",
"2.4-1",
"2.4.1-1",
"2.4.1-2",
"2.5-1",
"2.6-1",
"2.7-1",
"2.7-2",
"2.8.1-1",
"2.8.3-1",
"2.8.4-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49477.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "soupsieve",
"purl": "pkg:deb/debian/soupsieve?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.7-1",
"2.7-2",
"2.8.1-1",
"2.8.3-1",
"2.8.4-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49477.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.8.4-1"
}
]
}
],
"package": {
"name": "soupsieve",
"purl": "pkg:deb/debian/soupsieve?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.7-1",
"2.7-2",
"2.8.1-1",
"2.8.3-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49477.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #57277 · Revision 1
- Added to Heist Feed
- Publisher date