Skip to content
Heist/ feed
Medium

Apache APISIX: unauthenticated impersonation issue in saml-auth

Type: advisorySource: Official CVE List1 source record

Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Announced Group revision 1
Original source ↗

CVE-2026-94212

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: cve:CVE-2026-94212

Apache APISIX

Source reference: /containers/cna/affected/0/product

Affected versions
Not stated in this record
Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "vendor": "Apache Software Foundation",
    "product": "Apache APISIX",
    "versions": [
      {
        "status": "affected",
        "version": "3.17.0",
        "versionType": "semver",
        "lessThanOrEqual": "3.18.0"
      }
    ],
    "defaultStatus": "unaffected"
  }
]
Related CVEs
CVE-2026-94212

Source reference: /cveMetadata/cveId

Publisher severity

medium

Source reference: /containers/cna/metrics

Event
#5288 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement