DEBIAN-CVE-2026-33532
`yaml` is a YAML parser and serialiser for JavaScript. Parsing a YAML document with a version of `yaml` on the 1.x branch prior to 1.10.3 or on the 2.x branch prior to 2.8.3 may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a `RangeError: Maximum call stack size exceeded` with a small payload (~2–10 KB). The `RangeError` is not a `YAMLParseError`, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one `[` and one `]`). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's `Parser` (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve phase uses actual call-stack recursion. All three public parsing APIs are affected: `YAML.parse()`, `YAML.parseDocument()`, and `YAML.parseAllDocuments()`. Versions 1.10.3 and 2.8.3 contain a patch.
DEBIAN-CVE-2026-33532
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-33532
node-yaml
Source reference: /affected/0/package/name
- Affected versions
- 2.1.3-2
Source reference:
/affected/0/versions2.3.1-1Source reference:
/affected/0/versions2.3.1-2Source reference:
/affected/0/versions2.3.4+~cs0.4.0-1Source reference:
/affected/0/versions2.3.4-1Source reference:
/affected/0/versions2.8.2+~cs0.4.0-1Source reference:
/affected/0/versions2.8.3+~cs0.4.0-1Source reference:
/affected/0/versions2.8.3+~cs0.4.0-2Source reference:
/affected/0/versions2.8.3+~cs0.4.0-3Source reference:
/affected/0/versions2.9.0+~cs0.4.0-1Source reference:
/affected/0/versions2.9.0+~cs0.4.0-2Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-yaml
Source reference: /affected/1/package/name
- Affected versions
- 2.3.4+~cs0.4.0-1
Source reference:
/affected/1/versions2.8.2+~cs0.4.0-1Source reference:
/affected/1/versions2.8.3+~cs0.4.0-1Source reference:
/affected/1/versions2.8.3+~cs0.4.0-2Source reference:
/affected/1/versions2.8.3+~cs0.4.0-3Source reference:
/affected/1/versions2.9.0+~cs0.4.0-1Source reference:
/affected/1/versions2.9.0+~cs0.4.0-2Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-yaml
Source reference: /affected/2/package/name
- Affected versions
- 2.3.4+~cs0.4.0-1
Source reference:
/affected/2/versions2.8.2+~cs0.4.0-1Source reference:
/affected/2/versions - Fixed versions
- 2.8.3+~cs0.4.0-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-yaml",
"purl": "pkg:deb/debian/node-yaml?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.1.3-2",
"2.3.1-1",
"2.3.1-2",
"2.3.4+~cs0.4.0-1",
"2.3.4-1",
"2.8.2+~cs0.4.0-1",
"2.8.3+~cs0.4.0-1",
"2.8.3+~cs0.4.0-2",
"2.8.3+~cs0.4.0-3",
"2.9.0+~cs0.4.0-1",
"2.9.0+~cs0.4.0-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33532.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-yaml",
"purl": "pkg:deb/debian/node-yaml?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.3.4+~cs0.4.0-1",
"2.8.2+~cs0.4.0-1",
"2.8.3+~cs0.4.0-1",
"2.8.3+~cs0.4.0-2",
"2.8.3+~cs0.4.0-3",
"2.9.0+~cs0.4.0-1",
"2.9.0+~cs0.4.0-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33532.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.8.3+~cs0.4.0-1"
}
]
}
],
"package": {
"name": "node-yaml",
"purl": "pkg:deb/debian/node-yaml?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.3.4+~cs0.4.0-1",
"2.8.2+~cs0.4.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33532.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56406 · Revision 1
- Added to Heist Feed
- Publisher date