Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-6667

Type: advisorySource: OSV1 source record

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Announced Group revision 1
Original source ↗

DEBIAN-CVE-2026-6667

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-6667

pgbouncer

Source reference: /affected/0/package/name

Affected versions
1.18.0-1

Source reference: /affected/0/versions

1.18.0-1+deb12u1

Source reference: /affected/0/versions

1.19.0-1

Source reference: /affected/0/versions

1.19.1-1

Source reference: /affected/0/versions

1.20.0-1

Source reference: /affected/0/versions

1.20.1-1

Source reference: /affected/0/versions

1.21.0-1

Source reference: /affected/0/versions

1.22.0-1

Source reference: /affected/0/versions

1.22.1-1

Source reference: /affected/0/versions

1.23.0-1

Source reference: /affected/0/versions

1.23.1-1

Source reference: /affected/0/versions

1.24.0-2

Source reference: /affected/0/versions

1.24.0-3

Source reference: /affected/0/versions

1.24.1-1

Source reference: /affected/0/versions

1.25.0-1

Source reference: /affected/0/versions

1.25.0-2

Source reference: /affected/0/versions

1.25.1-1

Source reference: /affected/0/versions

1.25.2-1

Source reference: /affected/0/versions

1.26.0-1

Source reference: /affected/0/versions

1.26.0-2

Source reference: /affected/0/versions

1.26.0-3

Source reference: /affected/0/versions

1.26.0-4

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

pgbouncer

Source reference: /affected/1/package/name

Affected versions
1.24.1-1

Source reference: /affected/1/versions

1.24.1-1+deb13u1

Source reference: /affected/1/versions

Fixed versions
1.24.1-1+deb13u2

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

pgbouncer

Source reference: /affected/2/package/name

Affected versions
1.24.1-1

Source reference: /affected/2/versions

1.25.0-1

Source reference: /affected/2/versions

1.25.0-2

Source reference: /affected/2/versions

1.25.1-1

Source reference: /affected/2/versions

Fixed versions
1.25.2-1

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "pgbouncer",
      "purl": "pkg:deb/debian/pgbouncer?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "1.18.0-1",
      "1.18.0-1+deb12u1",
      "1.19.0-1",
      "1.19.1-1",
      "1.20.0-1",
      "1.20.1-1",
      "1.21.0-1",
      "1.22.0-1",
      "1.22.1-1",
      "1.23.0-1",
      "1.23.1-1",
      "1.24.0-2",
      "1.24.0-3",
      "1.24.1-1",
      "1.25.0-1",
      "1.25.0-2",
      "1.25.1-1",
      "1.25.2-1",
      "1.26.0-1",
      "1.26.0-2",
      "1.26.0-3",
      "1.26.0-4"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6667.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1.24.1-1+deb13u2"
          }
        ]
      }
    ],
    "package": {
      "name": "pgbouncer",
      "purl": "pkg:deb/debian/pgbouncer?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "1.24.1-1",
      "1.24.1-1+deb13u1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6667.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1.25.2-1"
          }
        ]
      }
    ],
    "package": {
      "name": "pgbouncer",
      "purl": "pkg:deb/debian/pgbouncer?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "1.24.1-1",
      "1.25.0-1",
      "1.25.0-2",
      "1.25.1-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-6667.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#58281 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement