Skip to content
Heist/ feed
HighFix available

DEBIAN-CVE-2026-79769

Type: advisorySource: OSV1 source record

Nokogiri versions before 1.19.4 contain a possible invalid (out-of-bounds) memory read in the protected internal Node#initialize_copy_with_args helper behind Node#dup and #clone, which unwrapped its source argument as an xmlNode without a type check. If application code calls this protected method with a non-Node argument (e.g., a Namespace), it reads an xmlNs out of bounds, crashing the process. This is only triggerable by a programming error and cannot be triggered by untrusted input or normal use of the public API. Only CRuby is affected. Version 1.19.4 adds a type check and raises TypeError.

Announced Group revision 1
Original source ↗

DEBIAN-CVE-2026-79769

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-79769

ruby-nokogiri

Source reference: /affected/0/package/name

Affected versions
1.18.10+dfsg-1

Source reference: /affected/0/versions

1.18.10+dfsg-2

Source reference: /affected/0/versions

1.18.10+dfsg-3

Source reference: /affected/0/versions

1.18.2+dfsg-1

Source reference: /affected/0/versions

1.19.1+dfsg-1

Source reference: /affected/0/versions

1.19.3+dfsg-1

Source reference: /affected/0/versions

1.19.4+dfsg-1

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

ruby-nokogiri

Source reference: /affected/1/package/name

Affected versions
1.18.10+dfsg-1

Source reference: /affected/1/versions

1.18.10+dfsg-2

Source reference: /affected/1/versions

1.18.10+dfsg-3

Source reference: /affected/1/versions

1.18.2+dfsg-1

Source reference: /affected/1/versions

1.19.1+dfsg-1

Source reference: /affected/1/versions

1.19.3+dfsg-1

Source reference: /affected/1/versions

Fixed versions
1.19.4+dfsg-1

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "ruby-nokogiri",
      "purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "1.18.10+dfsg-1",
      "1.18.10+dfsg-2",
      "1.18.10+dfsg-3",
      "1.18.2+dfsg-1",
      "1.19.1+dfsg-1",
      "1.19.3+dfsg-1",
      "1.19.4+dfsg-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-79769.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "1.19.4+dfsg-1"
          }
        ]
      }
    ],
    "package": {
      "name": "ruby-nokogiri",
      "purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "1.18.10+dfsg-1",
      "1.18.10+dfsg-2",
      "1.18.10+dfsg-3",
      "1.18.2+dfsg-1",
      "1.19.1+dfsg-1",
      "1.19.3+dfsg-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-79769.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]
Related CVEs
CVE-2026-79769

Source reference: /upstream

Publisher severity

high

Source reference: /severity/0/score

Event
#81618 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement