DEBIAN-CVE-2026-67315
axios versions 0.31.0 before 0.33.0 and 1.15.0 before 1.18.0 fail to recognize 0.0.0.0 as a loopback address in shouldBypassProxy.js, allowing requests to 0.0.0.0 to bypass NO_PROXY rules. Attackers can supply 0.0.0.0 URLs to route requests through configured proxies, potentially exposing local services when the proxy can reach the destination.
DEBIAN-CVE-2026-67315
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-67315
node-axios
Source reference: /affected/0/package/name
- Affected versions
- 1.11.0+dfsg-1
Source reference:
/affected/0/versions1.12.1+dfsg-1Source reference:
/affected/0/versions1.13.1+dfsg-1Source reference:
/affected/0/versions1.13.2+dfsg-1Source reference:
/affected/0/versions1.14.0+dfsg-1Source reference:
/affected/0/versions1.15.0-1Source reference:
/affected/0/versions1.15.2-1Source reference:
/affected/0/versions1.16.0-1Source reference:
/affected/0/versions1.8.4+dfsg-1Source reference:
/affected/0/versions - Fixed versions
- 1.18.0-1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.18.0-1"
}
]
}
],
"package": {
"name": "node-axios",
"purl": "pkg:deb/debian/node-axios?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.11.0+dfsg-1",
"1.12.1+dfsg-1",
"1.13.1+dfsg-1",
"1.13.2+dfsg-1",
"1.14.0+dfsg-1",
"1.15.0-1",
"1.15.2-1",
"1.16.0-1",
"1.8.4+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-67315.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #58283 · Revision 1
- Added to Heist Feed
- Publisher date