DEBIAN-CVE-2026-25547
@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.
DEBIAN-CVE-2026-25547
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-25547
node-brace-expansion
Source reference: /affected/0/package/name
- Affected versions
- 2.0.1+~1.1.0-1
Source reference:
/affected/0/versions2.0.1+~1.1.0-2Source reference:
/affected/0/versions2.0.1-2Source reference:
/affected/0/versions2.0.3+~1.1.2-1Source reference:
/affected/0/versions2.0.3+~1.1.2-2Source reference:
/affected/0/versions2.0.3+~1.1.2-3Source reference:
/affected/0/versions2.1.4+~1.1.2-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-brace-expansion
Source reference: /affected/1/package/name
- Affected versions
- 2.0.1+~1.1.0-2
Source reference:
/affected/1/versions2.0.3+~1.1.2-1Source reference:
/affected/1/versions2.0.3+~1.1.2-2Source reference:
/affected/1/versions2.0.3+~1.1.2-3Source reference:
/affected/1/versions2.1.4+~1.1.2-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-brace-expansion
Source reference: /affected/2/package/name
- Affected versions
- 2.0.1+~1.1.0-2
Source reference:
/affected/2/versions2.0.3+~1.1.2-1Source reference:
/affected/2/versions - Fixed versions
- 2.0.3+~1.1.2-2
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.0.1+~1.1.0-1",
"2.0.1+~1.1.0-2",
"2.0.1-2",
"2.0.3+~1.1.2-1",
"2.0.3+~1.1.2-2",
"2.0.3+~1.1.2-3",
"2.1.4+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-25547.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.0.1+~1.1.0-2",
"2.0.3+~1.1.2-1",
"2.0.3+~1.1.2-2",
"2.0.3+~1.1.2-3",
"2.1.4+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-25547.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.3+~1.1.2-2"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.0.1+~1.1.0-2",
"2.0.3+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-25547.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #57458 · Revision 1
- Added to Heist Feed
- Publisher date