High
CVE-2021-39242
An issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It can lead to a situation with an attacker-controlled HTTP Host header, because a mismatch between Host and authority is mishandled.
Announced Group revision 1
Original source ↗CVE-2021-39242
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:CVE-2021-39242
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"repo": "https://github.com/haproxy/haproxy",
"type": "GIT",
"events": [
{
"introduced": "6cbbecf09734aeb5fa8bb88f36f06a6f6d35e813"
},
{
"fixed": "a786c41f1fa7abf85e76abfe1ba09b0aed99190d"
}
],
"database_specific": {
"cpe": "cpe:2.3:a:haproxy:haproxy:*:*:*:*:*:*:*:*",
"source": "CPE_RANGE",
"extracted_events": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.3"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-39242.json"
}
}
]- Related CVEs
- CVE-2021-39242
Source reference:
/id
Publisher severity
high
Source reference: /severity/0/score
- Event
- #75215 · Revision 1
- Added to Heist Feed
- Publisher date