DEBIAN-CVE-2025-65082
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.
DEBIAN-CVE-2025-65082
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2025-65082
apache2
Source reference: /affected/0/package/name
- Affected versions
- 2.4.57-2
Source reference:
/affected/0/versions2.4.57-3Source reference:
/affected/0/versions2.4.58-1Source reference:
/affected/0/versions2.4.59-1Source reference:
/affected/0/versions2.4.59-1~deb10u1Source reference:
/affected/0/versions2.4.59-1~deb11u1Source reference:
/affected/0/versions2.4.59-1~deb12u1Source reference:
/affected/0/versions2.4.59-2Source reference:
/affected/0/versions2.4.60-1Source reference:
/affected/0/versions2.4.61-1Source reference:
/affected/0/versions2.4.61-1~deb11u1Source reference:
/affected/0/versions2.4.61-1~deb12u1Source reference:
/affected/0/versions2.4.62-1Source reference:
/affected/0/versions2.4.62-1~deb11u1Source reference:
/affected/0/versions2.4.62-1~deb11u2Source reference:
/affected/0/versions2.4.62-1~deb12u1Source reference:
/affected/0/versions2.4.62-1~deb12u2Source reference:
/affected/0/versions2.4.62-2Source reference:
/affected/0/versions2.4.62-3Source reference:
/affected/0/versions2.4.62-4Source reference:
/affected/0/versions2.4.62-5Source reference:
/affected/0/versions2.4.62-6Source reference:
/affected/0/versions2.4.63-1Source reference:
/affected/0/versions2.4.64-1Source reference:
/affected/0/versions2.4.65-1Source reference:
/affected/0/versions2.4.65-1~deb11u1Source reference:
/affected/0/versions2.4.65-1~deb12u1Source reference:
/affected/0/versions2.4.65-2Source reference:
/affected/0/versions2.4.65-3Source reference:
/affected/0/versions2.4.66-1~deb11u1Source reference:
/affected/0/versions - Fixed versions
- 2.4.66-1~deb12u1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
apache2
Source reference: /affected/1/package/name
- Affected versions
- 2.4.65-2
Source reference:
/affected/1/versions2.4.65-3Source reference:
/affected/1/versions2.4.66-1~deb11u1Source reference:
/affected/1/versions2.4.66-1~deb12u1Source reference:
/affected/1/versions2.4.66-1~deb12u2Source reference:
/affected/1/versions - Fixed versions
- 2.4.66-1~deb13u1
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
apache2
Source reference: /affected/2/package/name
- Affected versions
- 2.4.65-2
Source reference:
/affected/2/versions2.4.65-3Source reference:
/affected/2/versions2.4.66-1~deb11u1Source reference:
/affected/2/versions2.4.66-1~deb12u1Source reference:
/affected/2/versions2.4.66-1~deb12u2Source reference:
/affected/2/versions2.4.66-1~deb13u1Source reference:
/affected/2/versions2.4.66-1~deb13u2Source reference:
/affected/2/versions - Fixed versions
- 2.4.66-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.66-1~deb12u1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.4.57-2",
"2.4.57-3",
"2.4.58-1",
"2.4.59-1",
"2.4.59-1~deb10u1",
"2.4.59-1~deb11u1",
"2.4.59-1~deb12u1",
"2.4.59-2",
"2.4.60-1",
"2.4.61-1",
"2.4.61-1~deb11u1",
"2.4.61-1~deb12u1",
"2.4.62-1",
"2.4.62-1~deb11u1",
"2.4.62-1~deb11u2",
"2.4.62-1~deb12u1",
"2.4.62-1~deb12u2",
"2.4.62-2",
"2.4.62-3",
"2.4.62-4",
"2.4.62-5",
"2.4.62-6",
"2.4.63-1",
"2.4.64-1",
"2.4.65-1",
"2.4.65-1~deb11u1",
"2.4.65-1~deb12u1",
"2.4.65-2",
"2.4.65-3",
"2.4.66-1~deb11u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-65082.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.66-1~deb13u1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.4.65-2",
"2.4.65-3",
"2.4.66-1~deb11u1",
"2.4.66-1~deb12u1",
"2.4.66-1~deb12u2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-65082.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.66-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.4.65-2",
"2.4.65-3",
"2.4.66-1~deb11u1",
"2.4.66-1~deb12u1",
"2.4.66-1~deb12u2",
"2.4.66-1~deb13u1",
"2.4.66-1~deb13u2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-65082.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #18745 · Revision 1
- Added to Heist Feed
- Publisher date