Skip to content
Heist/ feed
HighFix available

GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute

Type: advisorySource: OSV1 source record

An issue in GoBGP gobgpd v.4.2.0 allows a remote attacker to cause a denial of service via the NEXT_HOP path attribute.

Announced Group revision 1
Original source ↗

GHSA-4p9m-8gc4-rw2h

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:GHSA-4p9m-8gc4-rw2h

github.com/osrg/gobgp/v4

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
4.4.0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "SEMVER",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "4.4.0"
          }
        ]
      }
    ],
    "package": {
      "name": "github.com/osrg/gobgp/v4",
      "purl": "pkg:golang/github.com/osrg/gobgp/v4",
      "ecosystem": "Go"
    },
    "database_specific": {
      "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/03/GHSA-4p9m-8gc4-rw2h/GHSA-4p9m-8gc4-rw2h.json",
      "last_known_affected_version_range": "<= 4.3.0"
    }
  }
]
Related CVEs
CVE-2026-30405

Source reference: /aliases

Publisher severity

high

Source reference: /database_specific/severity

Event
#71642 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement