Backstage: Inconsistent credential enforcement for overlapping proxy routes
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVE-2026-106456
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: cve:CVE-2026-106456
backstage
Source reference: /containers/cna/affected/0/product
- Affected versions
- Not stated in this record
- Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
plugin-proxy-backend
Source reference: /containers/cna/affected/1/product
- Affected versions
- Not stated in this record
- Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"vendor": "backstage",
"product": "backstage",
"versions": [
{
"status": "affected",
"version": ">= 1.28.0, < 1.55.0"
}
]
},
{
"vendor": "@backstage",
"product": "plugin-proxy-backend",
"versions": [
{
"status": "affected",
"version": ">= 0.5.0, < 0.6.18"
}
]
}
]- Related CVEs
- CVE-2026-106456
Source reference:
/cveMetadata/cveId
Publisher severity
medium
Source reference: /containers/cna/metrics
- Event
- #12114 · Revision 1
- Added to Heist Feed
- Publisher date