getkirby Kirby Dynamic Option Generation OptionsQuery.php resolve authorization
A vulnerability was identified in getkirby Kirby up to 4.9.5/5.5.3. Affected by this issue is the function OptionsQuery::resolve of the file src/Option/OptionsQuery.php of the component Dynamic Option Generation. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. Upgrading to version 4.9.6 and 5.6.0 can resolve this issue. You should upgrade the affected component.
CVE-2026-108924
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: cve:CVE-2026-108924
Kirby
Source reference: /containers/cna/affected/0/product
- Affected versions
- Not stated in this record
- Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"cpes": [
"cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*"
],
"vendor": "getkirby",
"modules": [
"Dynamic Option Generation"
],
"product": "Kirby",
"versions": [
{
"status": "affected",
"version": "4.9.0"
},
{
"status": "affected",
"version": "4.9.1"
},
{
"status": "affected",
"version": "4.9.2"
},
{
"status": "affected",
"version": "4.9.3"
},
{
"status": "affected",
"version": "4.9.4"
},
{
"status": "affected",
"version": "4.9.5"
},
{
"status": "affected",
"version": "5.5.0"
},
{
"status": "affected",
"version": "5.5.1"
},
{
"status": "affected",
"version": "5.5.2"
},
{
"status": "affected",
"version": "5.5.3"
},
{
"status": "unaffected",
"version": "4.9.6"
},
{
"status": "unaffected",
"version": "5.6.0"
}
]
}
]- Related CVEs
- CVE-2026-108924
Source reference:
/cveMetadata/cveId
Publisher severity
medium
Source reference: /containers/cna/metrics
- Event
- #32849 · Revision 1
- Added to Heist Feed
- Publisher date