UBUNTU-CVE-2026-96883
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
UBUNTU-CVE-2026-96883
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:UBUNTU-CVE-2026-96883
postgresql-9.3
Source reference: /affected/0/package/name
- Affected versions
- 9.3.1-1
Source reference:
/affected/0/versions9.3.2-1Source reference:
/affected/0/versions9.3.2-1ubuntu1Source reference:
/affected/0/versions9.3.2-1ubuntu2Source reference:
/affected/0/versions9.3.3-1Source reference:
/affected/0/versions9.3.3-1bzr1Source reference:
/affected/0/versions9.3.3-1bzr2Source reference:
/affected/0/versions9.3.4-1Source reference:
/affected/0/versions9.3.5-0ubuntu0.14.04.1Source reference:
/affected/0/versions9.3.6-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.7-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.8-0ubuntu0.4.04Source reference:
/affected/0/versions9.3.9-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.10-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.11-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.12-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.13-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.14-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.15-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.16-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.17-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.18-0ubuntu0.14.04.1Source reference:
/affected/0/versions9.3.19-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.20-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.21-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.22-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.23-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.24-0ubuntu0.14.04Source reference:
/affected/0/versions9.3.24-0ubuntu0.14.04+esm1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "postgresql-9.3",
"purl": "pkg:deb/ubuntu/postgresql-9.3?arch=source&distro=esm-infra-legacy%2Ftrusty",
"ecosystem": "Ubuntu:Pro:14.04:LTS"
},
"versions": [
"9.3.1-1",
"9.3.2-1",
"9.3.2-1ubuntu1",
"9.3.2-1ubuntu2",
"9.3.3-1",
"9.3.3-1bzr1",
"9.3.3-1bzr2",
"9.3.4-1",
"9.3.5-0ubuntu0.14.04.1",
"9.3.6-0ubuntu0.14.04",
"9.3.7-0ubuntu0.14.04",
"9.3.8-0ubuntu0.4.04",
"9.3.9-0ubuntu0.14.04",
"9.3.10-0ubuntu0.14.04",
"9.3.11-0ubuntu0.14.04",
"9.3.12-0ubuntu0.14.04",
"9.3.13-0ubuntu0.14.04",
"9.3.14-0ubuntu0.14.04",
"9.3.15-0ubuntu0.14.04",
"9.3.16-0ubuntu0.14.04",
"9.3.17-0ubuntu0.14.04",
"9.3.18-0ubuntu0.14.04.1",
"9.3.19-0ubuntu0.14.04",
"9.3.20-0ubuntu0.14.04",
"9.3.21-0ubuntu0.14.04",
"9.3.22-0ubuntu0.14.04",
"9.3.23-0ubuntu0.14.04",
"9.3.24-0ubuntu0.14.04",
"9.3.24-0ubuntu0.14.04+esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-96883.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libecpg-compat3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "libecpg6",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "libpgtypes3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "libpq5",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-client-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-contrib-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-doc-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-plperl-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-plpython-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-plpython3-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-pltcl-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
},
{
"binary_name": "postgresql-server-dev-9.3",
"binary_version": "9.3.24-0ubuntu0.14.04+esm1"
}
]
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #50911 · Revision 1
- Added to Heist Feed
- Publisher date