Skip to content
Heist/ feed
HighFix available

python-jupyterlab security update

Type: advisorySource: OSV1 source record

JupyterLab is the next-generation user interface for Project Jupyter offering all the familiar building blocks of the classic Jupyter Notebook (notebook, terminal, text editor, file browser, rich outputs, etc.) in a flexible and powerful user interface. Security Fix(es): JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.(CVE-2026-67338) JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.(CVE-2026-73626)

Announced Source revision 1
Original source ↗

OESA-2026-4168

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:OESA-2026-4168

python-jupyterlab

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
4.3.5-5.oe2403sp4

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "4.3.5-5.oe2403sp4"
          }
        ]
      }
    ],
    "package": {
      "name": "python-jupyterlab",
      "purl": "pkg:rpm/openEuler/python-jupyterlab&distro=openEuler-24.03-LTS-SP4",
      "ecosystem": "openEuler:24.03-LTS-SP4"
    },
    "database_specific": {
      "source": "https://repo.openeuler.org/security/data/osv/OESA-2026-4168.json"
    },
    "ecosystem_specific": {
      "src": [
        "python-jupyterlab-4.3.5-5.oe2403sp4.src.rpm"
      ],
      "noarch": [
        "python3-jupyterlab-4.3.5-5.oe2403sp4.noarch.rpm"
      ]
    }
  }
]

Publisher severity

high

Source reference: /database_specific/severity

Event
#52088 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement