Skip to content
Heist/ feed
UnratedFix available

ALPINE-CVE-2026-33412

Type: advisorySource: OSV1 source record

Vim is an open source, command line text editor. Prior to version 9.2.0202, a command injection vulnerability exists in Vim's glob() function on Unix-like systems. By including a newline character (\n) in a pattern passed to glob(), an attacker may be able to execute arbitrary shell commands. This vulnerability depends on the user's 'shell' setting. This issue has been patched in version 9.2.0202.

Announced Source revision 1
Original source ↗

ALPINE-CVE-2026-33412

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:ALPINE-CVE-2026-33412

vim

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
9.2.0219-r0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "9.2.0219-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "vim",
      "purl": "pkg:apk/alpine/vim?arch=source",
      "ecosystem": "Alpine:v3.23"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-33412.json"
    },
    "ecosystem_specific": {}
  }
]

Publisher severity

No explicit severity was provided.

Event
#54273 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement