Skip to content
Heist/ feed
UnratedFix available

ALPINE-CVE-2026-39314

Type: advisorySource: OSV1 source record

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.16 and prior, an integer underflow vulnerability in _ppdCreateFromIPP() (cups/ppd-cache.c) allows any unprivileged local user to crash the cupsd root process by supplying a negative job-password-supported IPP attribute. The bounds check only caps the upper bound, so a negative value passes validation, is cast to size_t (wrapping to ~2^64), and is used as the length argument to memset() on a 33-byte stack buffer. This causes an immediate SIGSEGV in the cupsd root process. Combined with systemd's Restart=on-failure, an attacker can repeat the crash for sustained denial of service.

Announced Source revision 1
Original source ↗

ALPINE-CVE-2026-39314

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:ALPINE-CVE-2026-39314

cups

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
2.4.18-r0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

cups

Source reference: /affected/1/package/name

Affected versions
Not stated in this record
Fixed versions
2.4.18-r0

Source reference: /affected/1/ranges

Prerequisites
Not stated in this record

cups

Source reference: /affected/2/package/name

Affected versions
Not stated in this record
Fixed versions
2.4.18-r0

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

cups

Source reference: /affected/3/package/name

Affected versions
Not stated in this record
Fixed versions
2.4.18-r0

Source reference: /affected/3/ranges

Prerequisites
Not stated in this record

cups

Source reference: /affected/4/package/name

Affected versions
Not stated in this record
Fixed versions
2.4.18-r0

Source reference: /affected/4/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.4.18-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "cups",
      "purl": "pkg:apk/alpine/cups?arch=source",
      "ecosystem": "Alpine:v3.20"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-39314.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.4.18-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "cups",
      "purl": "pkg:apk/alpine/cups?arch=source",
      "ecosystem": "Alpine:v3.21"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-39314.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.4.18-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "cups",
      "purl": "pkg:apk/alpine/cups?arch=source",
      "ecosystem": "Alpine:v3.22"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-39314.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.4.18-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "cups",
      "purl": "pkg:apk/alpine/cups?arch=source",
      "ecosystem": "Alpine:v3.23"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-39314.json"
    },
    "ecosystem_specific": {}
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.4.18-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "cups",
      "purl": "pkg:apk/alpine/cups?arch=source",
      "ecosystem": "Alpine:v3.24"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-39314.json"
    },
    "ecosystem_specific": {}
  }
]

Publisher severity

No explicit severity was provided.

Event
#54323 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement