Skip to content
Heist/ feed
UnratedFix available

ALPINE-CVE-2026-4176

Type: advisorySource: OSV1 source record

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.

Announced Source revision 1
Original source ↗

ALPINE-CVE-2026-4176

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:ALPINE-CVE-2026-4176

perl

Source reference: /affected/0/package/name

Affected versions
Not stated in this record
Fixed versions
5.42.2-r0

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "5.9.4"
          },
          {
            "fixed": "5.42.2-r0"
          }
        ]
      }
    ],
    "package": {
      "name": "perl",
      "purl": "pkg:apk/alpine/perl?arch=source",
      "ecosystem": "Alpine:v3.24"
    },
    "database_specific": {
      "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-4176.json"
    },
    "ecosystem_specific": {}
  }
]

Publisher severity

No explicit severity was provided.

Event
#54362 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement