ALPINE-CVE-2026-6464
Untrusted data inclusion in PostgreSQL psql COPY may allow a server administrator to elicit execution of data lines as psql commands, via error injection. If the "COPY FROM STDIN" or "\copy FROM STDIN" command fails before the server indicates that it awaits input rows, psql processes the in-line data rows as psql commands. "COPY FROM" with a filename is unaffected. The server administrator has no inherent control over the data rows, so a complete attack requires the attacker to separately acquire control of both the server and the data rows. Alternatively, an attacker controlling data rows alone might complete an attack through a coincidental error that they don't control. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
ALPINE-CVE-2026-6464
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:ALPINE-CVE-2026-6464
postgresql16
Source reference: /affected/0/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 16.15-r0
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
postgresql16
Source reference: /affected/1/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 16.15-r0
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
postgresql17
Source reference: /affected/2/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 17.11-r0
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
postgresql17
Source reference: /affected/3/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 17.11-r0
Source reference:
/affected/3/ranges - Prerequisites
- Not stated in this record
postgresql17
Source reference: /affected/4/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 17.11-r0
Source reference:
/affected/4/ranges - Prerequisites
- Not stated in this record
postgresql17
Source reference: /affected/5/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 17.11-r0
Source reference:
/affected/5/ranges - Prerequisites
- Not stated in this record
postgresql18
Source reference: /affected/6/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 18.5-r0
Source reference:
/affected/6/ranges - Prerequisites
- Not stated in this record
postgresql18
Source reference: /affected/7/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 18.5-r0
Source reference:
/affected/7/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "16.15-r0"
}
]
}
],
"package": {
"name": "postgresql16",
"purl": "pkg:apk/alpine/postgresql16?arch=source",
"ecosystem": "Alpine:v3.21"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "16.15-r0"
}
]
}
],
"package": {
"name": "postgresql16",
"purl": "pkg:apk/alpine/postgresql16?arch=source",
"ecosystem": "Alpine:v3.22"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.11-r0"
}
]
}
],
"package": {
"name": "postgresql17",
"purl": "pkg:apk/alpine/postgresql17?arch=source",
"ecosystem": "Alpine:v3.21"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.11-r0"
}
]
}
],
"package": {
"name": "postgresql17",
"purl": "pkg:apk/alpine/postgresql17?arch=source",
"ecosystem": "Alpine:v3.22"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.11-r0"
}
]
}
],
"package": {
"name": "postgresql17",
"purl": "pkg:apk/alpine/postgresql17?arch=source",
"ecosystem": "Alpine:v3.23"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.11-r0"
}
]
}
],
"package": {
"name": "postgresql17",
"purl": "pkg:apk/alpine/postgresql17?arch=source",
"ecosystem": "Alpine:v3.24"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.5-r0"
}
]
}
],
"package": {
"name": "postgresql18",
"purl": "pkg:apk/alpine/postgresql18?arch=source",
"ecosystem": "Alpine:v3.23"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.5-r0"
}
]
}
],
"package": {
"name": "postgresql18",
"purl": "pkg:apk/alpine/postgresql18?arch=source",
"ecosystem": "Alpine:v3.24"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-6464.json"
},
"ecosystem_specific": {}
}
]Publisher severity
No explicit severity was provided.
- Event
- #54619 · Revision 1
- Added to Heist Feed
- Publisher date