Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-14676

Type: advisorySource: OSV1 source record

Heap buffer overflow in PostgreSQL pg_stat_statements allows the query author to execute arbitrary code as the operating system user running the database, via crafted queries containing array constants. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

Announced Source revision 1
Original source ↗

DEBIAN-CVE-2026-14676

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-14676

postgresql-18

Source reference: /affected/0/package/name

Affected versions
18.0-1

Source reference: /affected/0/versions

18.1-1

Source reference: /affected/0/versions

18.1-2

Source reference: /affected/0/versions

18.2-1

Source reference: /affected/0/versions

18.3-1

Source reference: /affected/0/versions

18.4-1

Source reference: /affected/0/versions

18~beta1+20250612-1

Source reference: /affected/0/versions

18~beta1+20250624-1

Source reference: /affected/0/versions

18~beta1+20250701-1

Source reference: /affected/0/versions

18~beta1-1

Source reference: /affected/0/versions

18~beta2-1

Source reference: /affected/0/versions

18~beta3-1

Source reference: /affected/0/versions

18~rc1-1

Source reference: /affected/0/versions

18~rc1-2

Source reference: /affected/0/versions

18~rc1-3

Source reference: /affected/0/versions

18~~devel.20250318+g4078da6c478-1

Source reference: /affected/0/versions

18~~devel.20250331-1

Source reference: /affected/0/versions

18~~devel.20250405-1

Source reference: /affected/0/versions

18~~devel.20250421-1

Source reference: /affected/0/versions

18~~devel.20250502-1

Source reference: /affected/0/versions

Fixed versions
18.6-1

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "18.6-1"
          }
        ]
      }
    ],
    "package": {
      "name": "postgresql-18",
      "purl": "pkg:deb/debian/postgresql-18?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "18.0-1",
      "18.1-1",
      "18.1-2",
      "18.2-1",
      "18.3-1",
      "18.4-1",
      "18~beta1+20250612-1",
      "18~beta1+20250624-1",
      "18~beta1+20250701-1",
      "18~beta1-1",
      "18~beta2-1",
      "18~beta3-1",
      "18~rc1-1",
      "18~rc1-2",
      "18~rc1-3",
      "18~~devel.20250318+g4078da6c478-1",
      "18~~devel.20250331-1",
      "18~~devel.20250405-1",
      "18~~devel.20250421-1",
      "18~~devel.20250502-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-14676.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#55534 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement