Skip to content
Heist/ feed
Unrated

DEBIAN-CVE-2026-40466

Type: advisorySource: OSV1 source record

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath. A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.

Announced Source revision 1
Original source ↗

DEBIAN-CVE-2026-40466

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-40466

activemq

Source reference: /affected/0/package/name

Affected versions
5.17.2+dfsg-2

Source reference: /affected/0/versions

5.17.2+dfsg-2+deb12u1

Source reference: /affected/0/versions

5.17.6+dfsg-1

Source reference: /affected/0/versions

5.17.6+dfsg-2

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

activemq

Source reference: /affected/1/package/name

Affected versions
5.17.6+dfsg-2

Source reference: /affected/1/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "activemq",
      "purl": "pkg:deb/debian/activemq?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "5.17.2+dfsg-2",
      "5.17.2+dfsg-2+deb12u1",
      "5.17.6+dfsg-1",
      "5.17.6+dfsg-2"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-40466.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "activemq",
      "purl": "pkg:deb/debian/activemq?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "5.17.6+dfsg-2"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-40466.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#56022 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement