DEBIAN-CVE-2026-2391
### Summary The `arrayLimit` option in qs does not enforce limits for comma-separated values when `comma: true` is enabled, allowing attackers to cause denial-of-service via memory exhaustion. This is a bypass of the array limit enforcement, similar to the bracket notation bypass addressed in GHSA-6rw7-vpxm-498p (CVE-2025-15284). ### Details When the `comma` option is set to `true` (not the default, but configurable in applications), qs allows parsing comma-separated strings as arrays (e.g., `?param=a,b,c` becomes `['a', 'b', 'c']`). However, the limit check for `arrayLimit` (default: 20) and the optional throwOnLimitExceeded occur after the comma-handling logic in `parseArrayValue`, enabling a bypass. This permits creation of arbitrarily large arrays from a single parameter, leading to excessive memory allocation. **Vulnerable code** (lib/parse.js: lines ~40-50): ```js if (val && typeof val === 'string' && options.comma && val.indexOf(',') > -1) { return val.split(','); } if (options.throwOnLimitExceeded && currentArrayLength >= options.arrayLimit) { throw new RangeError('Array limit exceeded. Only ' + options.arrayLimit + ' element' + (options.arrayLimit === 1 ? '' : 's') + ' allowed in an array.'); } return val; ``` The `split(',')` returns the array immediately, skipping the subsequent limit check. Downstream merging via `utils.combine` does not prevent allocation, even if it marks overflows for sparse arrays.This discrepancy allows attackers to send a single parameter wi
DEBIAN-CVE-2026-2391
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-2391
node-qs
Source reference: /affected/0/package/name
- Affected versions
- 6.11.0+ds+~6.9.7-3
Source reference:
/affected/0/versions6.11.0+ds+~6.9.7-4Source reference:
/affected/0/versions6.13.0+ds+~6.9.16-1Source reference:
/affected/0/versions6.14.1+ds+~6.14.0-1Source reference:
/affected/0/versions6.15.0+ds+~6.15.0-1Source reference:
/affected/0/versions6.15.0+ds+~6.15.0-2Source reference:
/affected/0/versions6.15.0+ds+~6.15.0-3Source reference:
/affected/0/versions6.15.2+ds+~6.15.1-1Source reference:
/affected/0/versions6.16.0+ds+~6.15.1-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-qs
Source reference: /affected/1/package/name
- Affected versions
- 6.13.0+ds+~6.9.16-1
Source reference:
/affected/1/versions6.14.1+ds+~6.14.0-1Source reference:
/affected/1/versions6.15.0+ds+~6.15.0-1Source reference:
/affected/1/versions6.15.0+ds+~6.15.0-2Source reference:
/affected/1/versions6.15.0+ds+~6.15.0-3Source reference:
/affected/1/versions6.15.2+ds+~6.15.1-1Source reference:
/affected/1/versions6.16.0+ds+~6.15.1-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
node-qs
Source reference: /affected/2/package/name
- Affected versions
- 6.13.0+ds+~6.9.16-1
Source reference:
/affected/2/versions6.14.1+ds+~6.14.0-1Source reference:
/affected/2/versions - Fixed versions
- 6.15.0+ds+~6.15.0-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-qs",
"purl": "pkg:deb/debian/node-qs?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"6.11.0+ds+~6.9.7-3",
"6.11.0+ds+~6.9.7-4",
"6.13.0+ds+~6.9.16-1",
"6.14.1+ds+~6.14.0-1",
"6.15.0+ds+~6.15.0-1",
"6.15.0+ds+~6.15.0-2",
"6.15.0+ds+~6.15.0-3",
"6.15.2+ds+~6.15.1-1",
"6.16.0+ds+~6.15.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-2391.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-qs",
"purl": "pkg:deb/debian/node-qs?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"6.13.0+ds+~6.9.16-1",
"6.14.1+ds+~6.14.0-1",
"6.15.0+ds+~6.15.0-1",
"6.15.0+ds+~6.15.0-2",
"6.15.0+ds+~6.15.0-3",
"6.15.2+ds+~6.15.1-1",
"6.16.0+ds+~6.15.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-2391.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.15.0+ds+~6.15.0-1"
}
]
}
],
"package": {
"name": "node-qs",
"purl": "pkg:deb/debian/node-qs?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"6.13.0+ds+~6.9.16-1",
"6.14.1+ds+~6.14.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-2391.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56249 · Revision 1
- Added to Heist Feed
- Publisher date