Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-43970

Type: advisorySource: OSV1 source record

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in ninenines cowlib allows unauthenticated remote denial of service via memory exhaustion. cow_spdy:inflate/2 in cowlib passes peer-supplied compressed bytes directly to zlib:inflate/2 with no output size bound. The SPDY header compression dictionary (?ZDICT) is public, and zlib compresses long runs of repeated bytes at roughly 1024:1, so a few kilobytes of SPDY frame payload can decompress to gigabytes on the BEAM heap, OOM-killing the node. A single unauthenticated SPDY frame is sufficient to trigger the condition. The parsers for syn_stream, syn_reply, and headers frame types are all affected via cow_spdy:parse_headers/2. This issue affects cowlib from 0.1.0 before 2.16.1.

Announced Source revision 1
Original source ↗

DEBIAN-CVE-2026-43970

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-43970

erlang-cowlib

Source reference: /affected/0/package/name

Affected versions
1.3.0-3

Source reference: /affected/0/versions

2.17.1-1

Source reference: /affected/0/versions

2.17.1-2

Source reference: /affected/0/versions

2.18.0-1

Source reference: /affected/0/versions

2.19.0-1

Source reference: /affected/0/versions

2.20.0-1

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

erlang-cowlib

Source reference: /affected/1/package/name

Affected versions
1.3.0-3

Source reference: /affected/1/versions

2.17.1-1

Source reference: /affected/1/versions

2.17.1-2

Source reference: /affected/1/versions

2.18.0-1

Source reference: /affected/1/versions

2.19.0-1

Source reference: /affected/1/versions

2.20.0-1

Source reference: /affected/1/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

erlang-cowlib

Source reference: /affected/2/package/name

Affected versions
1.3.0-3

Source reference: /affected/2/versions

Fixed versions
2.17.1-1

Source reference: /affected/2/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "erlang-cowlib",
      "purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "1.3.0-3",
      "2.17.1-1",
      "2.17.1-2",
      "2.18.0-1",
      "2.19.0-1",
      "2.20.0-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "erlang-cowlib",
      "purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=trixie",
      "ecosystem": "Debian:13"
    },
    "versions": [
      "1.3.0-3",
      "2.17.1-1",
      "2.17.1-2",
      "2.18.0-1",
      "2.19.0-1",
      "2.20.0-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  },
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.17.1-1"
          }
        ]
      }
    ],
    "package": {
      "name": "erlang-cowlib",
      "purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "1.3.0-3"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#56540 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement