DEBIAN-CVE-2026-27601
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
DEBIAN-CVE-2026-27601
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-27601
underscore
Source reference: /affected/0/package/name
- Affected versions
- 1.13.4~dfsg+~1.11.4-3
Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-1Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-2Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-3Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-4Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-5Source reference:
/affected/0/versions1.13.7~dfsg+~1.13.0-6Source reference:
/affected/0/versions1.13.8~dfsg+~1.13.0-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
underscore
Source reference: /affected/1/package/name
- Affected versions
- 1.13.4~dfsg+~1.11.4-3
Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-1Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-2Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-3Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-4Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-5Source reference:
/affected/1/versions1.13.7~dfsg+~1.13.0-6Source reference:
/affected/1/versions1.13.8~dfsg+~1.13.0-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
underscore
Source reference: /affected/2/package/name
- Affected versions
- 1.13.4~dfsg+~1.11.4-3
Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-1Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-2Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-3Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-4Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-5Source reference:
/affected/2/versions1.13.7~dfsg+~1.13.0-6Source reference:
/affected/2/versions - Fixed versions
- 1.13.8~dfsg+~1.13.0-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.13.4~dfsg+~1.11.4-3",
"1.13.7~dfsg+~1.13.0-1",
"1.13.7~dfsg+~1.13.0-2",
"1.13.7~dfsg+~1.13.0-3",
"1.13.7~dfsg+~1.13.0-4",
"1.13.7~dfsg+~1.13.0-5",
"1.13.7~dfsg+~1.13.0-6",
"1.13.8~dfsg+~1.13.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27601.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.13.4~dfsg+~1.11.4-3",
"1.13.7~dfsg+~1.13.0-1",
"1.13.7~dfsg+~1.13.0-2",
"1.13.7~dfsg+~1.13.0-3",
"1.13.7~dfsg+~1.13.0-4",
"1.13.7~dfsg+~1.13.0-5",
"1.13.7~dfsg+~1.13.0-6",
"1.13.8~dfsg+~1.13.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27601.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.8~dfsg+~1.13.0-1"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.13.4~dfsg+~1.11.4-3",
"1.13.7~dfsg+~1.13.0-1",
"1.13.7~dfsg+~1.13.0-2",
"1.13.7~dfsg+~1.13.0-3",
"1.13.7~dfsg+~1.13.0-4",
"1.13.7~dfsg+~1.13.0-5",
"1.13.7~dfsg+~1.13.0-6"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27601.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #56712 · Revision 1
- Added to Heist Feed
- Publisher date