Skip to content
Heist/ feed
UnratedFix available

DEBIAN-CVE-2026-50195

Type: advisorySource: OSV1 source record

containerd is an open-source container runtime. Versions prior to 2.3.2, 2.2.5 and 2.1.9 contain a vulnerability in the CRI checkpoint import process where it fails to validate the image references specified within a checkpoint image's configuration. An attacker with permissions to create pods can use a crafted checkpoint image to force containerd to pull a malicious image and assign it an arbitrary local tag, thereby poisoning the node's local image cache. Subsequently, if other pods on the same node attempt to use the poisoned tag with an IfNotPresent (or Never) pull policy, they will unknowingly execute the attacker's malicious image instead of the legitimate one. This can lead to a compromise of the affected pods, allowing the attacker to execute arbitrary code under the victim pod's identity. This issue has been fixed in versions 2.3.2, 2.2.5 and 2.1.9.

Announced Source revision 1
Original source ↗

DEBIAN-CVE-2026-50195

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-50195

containerd

Source reference: /affected/0/package/name

Affected versions
1.7.24~ds1-10

Source reference: /affected/0/versions

1.7.24~ds1-6

Source reference: /affected/0/versions

1.7.24~ds1-7

Source reference: /affected/0/versions

1.7.24~ds1-8

Source reference: /affected/0/versions

1.7.24~ds1-9

Source reference: /affected/0/versions

2.1.4~ds2-2

Source reference: /affected/0/versions

2.1.4~ds2-3

Source reference: /affected/0/versions

2.1.4~ds2-4

Source reference: /affected/0/versions

2.1.4~ds2-5

Source reference: /affected/0/versions

2.1.4~ds2-6

Source reference: /affected/0/versions

2.1.4~ds2-7

Source reference: /affected/0/versions

2.1.4~ds2-8

Source reference: /affected/0/versions

2.1.6+ds1-1

Source reference: /affected/0/versions

Fixed versions
2.1.9+ds1-1

Source reference: /affected/0/ranges

Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          },
          {
            "fixed": "2.1.9+ds1-1"
          }
        ]
      }
    ],
    "package": {
      "name": "containerd",
      "purl": "pkg:deb/debian/containerd?arch=source&distro=forky",
      "ecosystem": "Debian:14"
    },
    "versions": [
      "1.7.24~ds1-10",
      "1.7.24~ds1-6",
      "1.7.24~ds1-7",
      "1.7.24~ds1-8",
      "1.7.24~ds1-9",
      "2.1.4~ds2-2",
      "2.1.4~ds2-3",
      "2.1.4~ds2-4",
      "2.1.4~ds2-5",
      "2.1.4~ds2-6",
      "2.1.4~ds2-7",
      "2.1.4~ds2-8",
      "2.1.6+ds1-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-50195.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]

Publisher severity

No explicit severity was provided.

Event
#57288 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement