DEBIAN-CVE-2026-54163
secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.
DEBIAN-CVE-2026-54163
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-54163
ruby-secure-headers
Source reference: /affected/0/package/name
- Affected versions
- 6.3.2-1
Source reference:
/affected/0/versions6.3.2-2Source reference:
/affected/0/versions7.1.0-1Source reference:
/affected/0/versions7.2.0-1Source reference:
/affected/0/versions7.3.0-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
ruby-secure-headers
Source reference: /affected/1/package/name
- Affected versions
- 6.3.2-2
Source reference:
/affected/1/versions7.1.0-1Source reference:
/affected/1/versions7.2.0-1Source reference:
/affected/1/versions7.3.0-1Source reference:
/affected/1/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
ruby-secure-headers
Source reference: /affected/2/package/name
- Affected versions
- 6.3.2-2
Source reference:
/affected/2/versions7.1.0-1Source reference:
/affected/2/versions7.2.0-1Source reference:
/affected/2/versions - Fixed versions
- 7.3.0-1
Source reference:
/affected/2/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-secure-headers",
"purl": "pkg:deb/debian/ruby-secure-headers?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"6.3.2-1",
"6.3.2-2",
"7.1.0-1",
"7.2.0-1",
"7.3.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54163.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-secure-headers",
"purl": "pkg:deb/debian/ruby-secure-headers?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"6.3.2-2",
"7.1.0-1",
"7.2.0-1",
"7.3.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54163.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.3.0-1"
}
]
}
],
"package": {
"name": "ruby-secure-headers",
"purl": "pkg:deb/debian/ruby-secure-headers?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"6.3.2-2",
"7.1.0-1",
"7.2.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54163.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #57856 · Revision 1
- Added to Heist Feed
- Publisher date