Microsoft Security Advisory CVE-2026-69439 – .NET and Visual Studio Elevation of Privilege Vulnerability
# Microsoft Security Advisory CVE-2026-69439 – .NET and Visual Studio Elevation of Privilege Vulnerability ## Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.DiaSymReader.Native. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An out of bounds write can occur when parsing a Portable PDB file. ## Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/438 ## CVSS Details - **Version:** 3.1 - **Severity:** High - **Score:** 8.8 - **Vector:** `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H` - **Weakness:** CWE-122 (Heap-based Buffer Overflow) ## Affected Platforms - **Platforms:** Windows - **Architectures:** All ## Affected Packages The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below ### .NET 11 RC1 Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- [Microsoft.DiaSymReader.Native](https://www.nuget.org/packages/Microsoft.DiaSymReader.Native) | >= 17.10.0-beta1.24272.1, <= 18.9.0-beta1.26405.1 | 18.9.0-beta1.26405.2 ### .NET 10 Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- [Microsoft.DiaSymReader.Native](https://www.nuget.org/packages/Microsoft.DiaSymReader.Native) | >= 17.12.0-beta1.24603.5, <= 18.9.0-beta1.26
GHSA-527h-q9f6-p7qx
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:GHSA-527h-q9f6-p7qx
Microsoft.DiaSymReader.Native
Source reference: /affected/0/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 18.9.0-beta1.26405.2
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "17.10.0-beta1.24272.1"
},
{
"fixed": "18.9.0-beta1.26405.2"
}
]
}
],
"package": {
"name": "Microsoft.DiaSymReader.Native",
"purl": "pkg:nuget/Microsoft.DiaSymReader.Native",
"ecosystem": "NuGet"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/09/GHSA-527h-q9f6-p7qx/GHSA-527h-q9f6-p7qx.json",
"last_known_affected_version_range": "<= 18.9.0-beta1.26405.1"
}
}
]- Related CVEs
- CVE-2026-69439
Source reference:
/aliases
Publisher severity
high
Source reference: /database_specific/severity
- Event
- #59627 · Revision 1
- Added to Heist Feed
- Publisher date