DEBIAN-CVE-2026-92973
ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.
DEBIAN-CVE-2026-92973
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-92973
python-ansi2html
Source reference: /affected/0/package/name
- Affected versions
- 1.9.2-1
Source reference:
/affected/0/versions1.9.2-2Source reference:
/affected/0/versions - Fixed versions
- 1.9.5-1
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.5-1"
}
]
}
],
"package": {
"name": "python-ansi2html",
"purl": "pkg:deb/debian/python-ansi2html?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.9.2-1",
"1.9.2-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-92973.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
]Publisher severity
No explicit severity was provided.
- Event
- #6081 · Revision 1
- Added to Heist Feed
- Publisher date