OpenCVE: Server-Side Request Forgery (SSRF) in notifications
### Impact OpenCVE contains a Server-Side Request Forgery (SSRF) vulnerability in the notification testing functionality for both Webhook and Slack integrations. An authenticated user with permission to configure notification channels can trigger test requests to arbitrary HTTP(S) endpoints. Insufficient validation of target destinations allows requests to be sent to hosts reachable from the OpenCVE server, including internal network resources, localhost interfaces, and cloud metadata services. Successful exploitation could allow an attacker to interact with internal services that are not otherwise accessible from the Internet and retrieve information from HTTP-based services reachable by the OpenCVE instance. ### Patches The vulnerability has been fixed in OpenCVE version 3.0.0, users should upgrade to version 3.0.0 or later. The fix introduces additional validation of user-supplied URLs used by the notification testing functionality and prevents requests to localhost, private network ranges, link-local addresses, cloud metadata services, and other non-public destinations. ### Workarounds Users unable to upgrade should restrict outbound network access from OpenCVE to trusted external destinations using firewall rules, network policies, or egress filtering. Where possible, access to localhost interfaces, private network ranges, and cloud metadata services should be blocked from the OpenCVE application environment. Disabling access to the notification testing functionality als
PYSEC-2026-4130
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:PYSEC-2026-4130
opencve
Source reference: /affected/0/package/name
- Affected versions
- 1.0.0
Source reference:
/affected/0/versions1.0.1Source reference:
/affected/0/versions1.0.2Source reference:
/affected/0/versions1.1.0Source reference:
/affected/0/versions1.2.0Source reference:
/affected/0/versions1.2.1Source reference:
/affected/0/versions1.2.2Source reference:
/affected/0/versions1.2.3Source reference:
/affected/0/versions1.3.0Source reference:
/affected/0/versions1.4.0Source reference:
/affected/0/versions1.4.1Source reference:
/affected/0/versions1.5.0Source reference:
/affected/0/versions - Fixed versions
- 3.0.0
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.0"
}
]
}
],
"package": {
"name": "opencve",
"purl": "pkg:pypi/opencve",
"ecosystem": "PyPI"
},
"versions": [
"1.0.0",
"1.0.1",
"1.0.2",
"1.1.0",
"1.2.0",
"1.2.1",
"1.2.2",
"1.2.3",
"1.3.0",
"1.4.0",
"1.4.1",
"1.5.0"
],
"database_specific": {
"source": "https://github.com/pypa/advisory-database/blob/main/vulns/opencve/PYSEC-2026-4130.yaml"
}
}
]- Related CVEs
- CVE-2026-62282
Source reference:
/aliases
Publisher severity
No explicit severity was provided.
- Event
- #62499 · Revision 1
- Added to Heist Feed
- Publisher date