RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
## Summary A structural security weakness exists in the AMQP client's TLS configuration generator (`tlsConfigFromURI`). When constructing a `*tls.Config` object from an `amqps://` connection URI, the library initializes the structure without explicitly defining the `MinVersion` field. While modern versions of the Go compiler toolchain (Go 1.18+) default the implicit minimum version to TLS 1.2, this security posture relies entirely on an implicit toolchain dependency. If the library is compiled using legacy Go toolchains (Go < 1.18), or if a future toolchain introduces fallback behavior, the client could silently negotiate obsolete and insecure TLS 1.0 or TLS 1.1 protocols during connection handshakes with a compromised or malicious AMQP broker. --- ## Vulnerability Details ### Mechanism The vulnerability lies in the lack of an explicit safety floor when assigning configurations inside the URI component: ```go // Example within uri.go's tlsConfigFromURI cfg := &tls.Config{ ServerName: host, // MinVersion is left completely unassigned (defaults to 0, or toolchain default) } ``` In the Go standard library (`crypto/tls`), leaving `MinVersion: 0` instructs the runtime to choose the toolchain's default minimum. Prior to Go 1.18, this default allowed negotiation down to TLS 1.0. Relying on implicit compiler configurations violates secure coding practices by decoupling the library's security posture from its source code, leaving applications vulnerable based solely on how they are bu
GHSA-33mj-cw25-m34h
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:GHSA-33mj-cw25-m34h
github.com/rabbitmq/amqp091-go
Source reference: /affected/0/package/name
- Affected versions
- Not stated in this record
- Fixed versions
- 1.13.0
Source reference:
/affected/0/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.0"
}
]
}
],
"package": {
"name": "github.com/rabbitmq/amqp091-go",
"purl": "pkg:golang/github.com/rabbitmq/amqp091-go",
"ecosystem": "Go"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/09/GHSA-33mj-cw25-m34h/GHSA-33mj-cw25-m34h.json"
}
}
]- Related CVEs
- CVE-2026-77405
Source reference:
/aliases
Publisher severity
critical
Source reference: /database_specific/severity
- Event
- #63938 · Revision 1
- Added to Heist Feed
- Publisher date