Skip to content
Heist/ feed
Critical

DEBIAN-CVE-2026-58154

Type: advisorySource: OSV1 source record

Apache Traffic Server can write out of bounds or overflow integers while parsing MIME and HTTP headers. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Announced Source revision 1
Original source ↗

DEBIAN-CVE-2026-58154

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: osv:DEBIAN-CVE-2026-58154

trafficserver

Source reference: /affected/0/package/name

Affected versions
9.2.0+ds-2

Source reference: /affected/0/versions

9.2.0+ds-2+deb12u1

Source reference: /affected/0/versions

9.2.1+ds-1

Source reference: /affected/0/versions

9.2.2+ds-1

Source reference: /affected/0/versions

9.2.3+ds-1

Source reference: /affected/0/versions

9.2.3+ds-1+deb12u1

Source reference: /affected/0/versions

9.2.4+ds-0+deb12u1

Source reference: /affected/0/versions

9.2.4+ds-1

Source reference: /affected/0/versions

9.2.4+ds-2

Source reference: /affected/0/versions

9.2.5+ds-0+deb12u1

Source reference: /affected/0/versions

9.2.5+ds-0+deb12u2

Source reference: /affected/0/versions

9.2.5+ds-0+deb12u3

Source reference: /affected/0/versions

9.2.5+ds-0+deb12u4

Source reference: /affected/0/versions

9.2.5+ds-1

Source reference: /affected/0/versions

Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "ranges": [
      {
        "type": "ECOSYSTEM",
        "events": [
          {
            "introduced": "0"
          }
        ]
      }
    ],
    "package": {
      "name": "trafficserver",
      "purl": "pkg:deb/debian/trafficserver?arch=source&distro=bookworm",
      "ecosystem": "Debian:12"
    },
    "versions": [
      "9.2.0+ds-2",
      "9.2.0+ds-2+deb12u1",
      "9.2.1+ds-1",
      "9.2.2+ds-1",
      "9.2.3+ds-1",
      "9.2.3+ds-1+deb12u1",
      "9.2.4+ds-0+deb12u1",
      "9.2.4+ds-1",
      "9.2.4+ds-2",
      "9.2.5+ds-0+deb12u1",
      "9.2.5+ds-0+deb12u2",
      "9.2.5+ds-0+deb12u3",
      "9.2.5+ds-0+deb12u4",
      "9.2.5+ds-1"
    ],
    "database_specific": {
      "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-58154.json"
    },
    "ecosystem_specific": {
      "urgency": "not yet assigned"
    }
  }
]
Related CVEs
CVE-2026-58154

Source reference: /upstream

Publisher severity

critical

Source reference: /severity/0/score

Linked CVE context

These ratings describe the referenced vulnerabilities and products. They are not a severity rating for every application using this dependency.

CVE-2026-58154 · Critical

Apache Traffic Server

Event
#67664 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement