DEBIAN-CVE-2026-18022
Integer wraparound in IVFFlat index build in pgvector before 0.8.6 allows a database user to write data out-of-bounds, which could lead to arbitrary code execution. Only 32-bit systems are affected.
DEBIAN-CVE-2026-18022
Primary source · Revision 1
Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.
Security context
Source reference: osv:DEBIAN-CVE-2026-18022
pgvector
Source reference: /affected/0/package/name
- Affected versions
- 0.8.0-1
Source reference:
/affected/0/versions0.8.1-1Source reference:
/affected/0/versions0.8.1-2Source reference:
/affected/0/versions0.8.2-1Source reference:
/affected/0/versions0.8.3-1Source reference:
/affected/0/versions0.8.4-1Source reference:
/affected/0/versions0.8.5-1Source reference:
/affected/0/versions0.8.6-1Source reference:
/affected/0/versions0.8.7-1Source reference:
/affected/0/versions - Fixed versions
- Not stated in this record
- Prerequisites
- Not stated in this record
pgvector
Source reference: /affected/1/package/name
- Affected versions
- 0.8.0-1
Source reference:
/affected/1/versions0.8.1-1Source reference:
/affected/1/versions0.8.1-2Source reference:
/affected/1/versions0.8.2-1Source reference:
/affected/1/versions0.8.3-1Source reference:
/affected/1/versions0.8.4-1Source reference:
/affected/1/versions0.8.5-1Source reference:
/affected/1/versions - Fixed versions
- 0.8.6-1
Source reference:
/affected/1/ranges - Prerequisites
- Not stated in this record
Structured affected-version data
Original package identities and version rules from this source.
[
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "pgvector",
"purl": "pkg:deb/debian/pgvector?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"0.8.0-1",
"0.8.1-1",
"0.8.1-2",
"0.8.2-1",
"0.8.3-1",
"0.8.4-1",
"0.8.5-1",
"0.8.6-1",
"0.8.7-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-18022.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8.6-1"
}
]
}
],
"package": {
"name": "pgvector",
"purl": "pkg:deb/debian/pgvector?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"0.8.0-1",
"0.8.1-1",
"0.8.1-2",
"0.8.2-1",
"0.8.3-1",
"0.8.4-1",
"0.8.5-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-18022.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
]- Related CVEs
- CVE-2026-18022
Source reference:
/upstream
Publisher severity
high
Source reference: /severity/0/score
- Event
- #71352 · Revision 1
- Added to Heist Feed
- Publisher date