UnratedFix available
io.js security patches 1.8.3 and 2.3.3
io.js released versions 1.8.3 and 2.3.3 to fix an out-of-band write in the utf8 decoder that could cause denial of service. The announcement also describes an OpenSSL upgrade in 1.8.3.
Announced Source revision 1
Original source ↗nodejs
Primary source · Revision 1
These are machine-extracted claims. Quotations show the recorded source text; verify the original announcement before acting.
Security context
v1.8.3 and v2.3.3, complete changelog from previous releases can be found on GitHub
io.js
all versions of io.js
- Affected versions
- v1.8.2 or below
If you're running v1.8.2 or below, or v2.3.2 or below
- Fixed versions
- 1.8.3
please update them to io.js versions 1.8.3 and 2.3.3
- Prerequisites
- Not stated in this extraction
io.js
all versions of io.js
- Affected versions
- v2.3.2 or below
If you're running v1.8.2 or below, or v2.3.2 or below
- Fixed versions
- 2.3.3
please update them to io.js versions 1.8.3 and 2.3.3
- Prerequisites
- Not stated in this extraction
- Related CVEs
- CVE-2015-1788
fixes malformed ECParameters causing infinite loop (CVE-2015-1788)
Publisher severity
No explicit severity was extracted.
- Event
- #72328 · Revision 1
- Added to Heist Feed
- Publisher date