Skip to content
Heist/ feed
High

Sakai Conversations has a Stored XSS Issue

Type: advisorySource: Official CVE List1 source record

Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.

Announced Source revision 1
Original source ↗

CVE-2026-54049

Primary source · Revision 1

Imported from structured advisory data. Source references identify upstream records or fields; verify affected versions and your deployed configuration.

Security context

Source reference: cve:CVE-2026-54049

sakai

Source reference: /containers/cna/affected/0/product

Affected versions
Not stated in this record
Fixed versions
Not stated in this record
Prerequisites
Not stated in this record

Structured affected-version data

Original package identities and version rules from this source.

[
  {
    "vendor": "sakaiproject",
    "product": "sakai",
    "versions": [
      {
        "status": "affected",
        "version": ">= 23.0, < 23.5"
      },
      {
        "status": "affected",
        "version": ">= 25.0, < 25.3"
      }
    ]
  }
]
Related CVEs
CVE-2026-54049

Source reference: /cveMetadata/cveId

Publisher severity

high

Source reference: /containers/cna/metrics

Event
#8995 · Revision 1
Added to Heist Feed
Publisher date
Read the original announcement